summaryrefslogtreecommitdiff
path: root/app-emacs/markdown-mode/markdown-mode-2.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/markdown-mode/markdown-mode-2.3.ebuild')
-rw-r--r--app-emacs/markdown-mode/markdown-mode-2.3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-emacs/markdown-mode/markdown-mode-2.3.ebuild b/app-emacs/markdown-mode/markdown-mode-2.3.ebuild
new file mode 100644
index 000000000000..1a8f2d0437c3
--- /dev/null
+++ b/app-emacs/markdown-mode/markdown-mode-2.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Major mode for editing Markdown-formatted text files"
+HOMEPAGE="https://jblevins.org/projects/markdown-mode/"
+SRC_URI="https://stable.melpa.org/packages/${P}.el"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="|| ( dev-python/markdown2 dev-python/markdown )"
+
+S="${WORKDIR}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_unpack() {
+ cp "${DISTDIR}"/${P}.el ${PN}.el || die
+}