summaryrefslogtreecommitdiff
path: root/app-emacs/magit/magit-2.90.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/magit/magit-2.90.1.ebuild')
-rw-r--r--app-emacs/magit/magit-2.90.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-emacs/magit/magit-2.90.1.ebuild b/app-emacs/magit/magit-2.90.1.ebuild
new file mode 100644
index 000000000000..b7659c893040
--- /dev/null
+++ b/app-emacs/magit/magit-2.90.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+NEED_EMACS=25
+
+inherit elisp
+
+DESCRIPTION="A Git porcelain inside Emacs"
+HOMEPAGE="https://magit.vc/"
+SRC_URI="https://github.com/magit/magit/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+S="${WORKDIR}/${P}/lisp"
+SITEFILE="50${PN}-gentoo.el"
+ELISP_TEXINFO="../Documentation/*.texi"
+DOCS="../README.md ../Documentation/AUTHORS.md ../Documentation/RelNotes/*"
+
+DEPEND="
+ >=app-emacs/dash-2.14.1
+ >=app-emacs/ghub-3.0.0
+ >=app-emacs/magit-popup-2.12.4
+ >=app-emacs/with-editor-2.8.0
+"
+RDEPEND="${DEPEND} >=dev-vcs/git-2.0.0"
+DEPEND="${DEPEND} sys-apps/texinfo"
+
+src_prepare() {
+ default
+ echo "(setq magit-version \"${PV}\")" > magit-version.el || die
+}