summaryrefslogtreecommitdiff
path: root/app-emacs/kind-icon/kind-icon-0.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/kind-icon/kind-icon-0.2.0.ebuild')
-rw-r--r--app-emacs/kind-icon/kind-icon-0.2.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-emacs/kind-icon/kind-icon-0.2.0.ebuild b/app-emacs/kind-icon/kind-icon-0.2.0.ebuild
new file mode 100644
index 000000000000..9941bb5d8d0e
--- /dev/null
+++ b/app-emacs/kind-icon/kind-icon-0.2.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS="27.1"
+inherit elisp
+
+DESCRIPTION="Completion kind icons"
+HOMEPAGE="https://github.com/jdtsmith/kind-icon"
+SRC_URI="https://dev.gentoo.org/~arsen/${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="app-emacs/svg-lib"
+DEPEND="${RDEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-make-autoload-file
+ elisp_src_compile
+}