summaryrefslogtreecommitdiff
path: root/app-emacs/filladapt/filladapt-2.12.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/filladapt/filladapt-2.12.2.ebuild')
-rw-r--r--app-emacs/filladapt/filladapt-2.12.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-emacs/filladapt/filladapt-2.12.2.ebuild b/app-emacs/filladapt/filladapt-2.12.2.ebuild
new file mode 100644
index 000000000000..e2880aa486fe
--- /dev/null
+++ b/app-emacs/filladapt/filladapt-2.12.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24.4
+
+inherit elisp readme.gentoo-r1
+
+DESCRIPTION="Filladapt enhances the behavior of Emacs' fill functions"
+HOMEPAGE="http://www.wonderworks.com/ https://elpa.gnu.org/packages/filladapt.html"
+SRC_URI="https://elpa.gnu.org/packages/${P}.el"
+S="${WORKDIR}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+SITEFILE="50${PN}-gentoo.el"
+DOC_CONTENTS="Filladapt is not enabled as a site default. Add the following
+ lines to your ~/.emacs file to enable adaptive fill by default:
+ \n\t(require 'filladapt)
+ \n\t(setq-default filladapt-mode t)"
+
+src_unpack() {
+ mv "${DISTDIR}"/${P}.el "${WORKDIR}"/${PN}.el || die
+}