summaryrefslogtreecommitdiff
path: root/app-emacs/fff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/fff')
-rw-r--r--app-emacs/fff/Manifest4
-rw-r--r--app-emacs/fff/fff-20050517.ebuild18
-rw-r--r--app-emacs/fff/files/50fff-gentoo.el17
-rw-r--r--app-emacs/fff/metadata.xml17
4 files changed, 56 insertions, 0 deletions
diff --git a/app-emacs/fff/Manifest b/app-emacs/fff/Manifest
new file mode 100644
index 000000000000..93fc855ac3b4
--- /dev/null
+++ b/app-emacs/fff/Manifest
@@ -0,0 +1,4 @@
+AUX 50fff-gentoo.el 911 BLAKE2B e26758fc4d072cdab055090879d3246583393f86491afe8fbd4ec24e4a40d02bd699a8695460a4840ad6fc0d59c37859a780e92ea5df622046a5f8cc12a58f96 SHA512 b5c50da8e123d8cac658d6ab4f9c1fb3c6c2186c90753c70b6453f611999979873234b270f0b9265b8e8c452c94541d140b6ae7631f546bf249968934bc36d4e
+DIST fff-20050517.tar.bz2 13774 BLAKE2B 2b98f7d7c1b557839a879375d92d6f030685956f60eceb5414afd31a629792afb41c5690f65e81edec7dfaca8407107c4d50a5f1a40989fdec55cc2cd6aaa34e SHA512 829a833a25378d868db0dad04d062c397336aa98167fd5706a9c75a7ec4c60a49bc77b5dfa9ed9f48565d09ae2817fafeffeb7546b5e5bbfcd13c78fcdfc9939
+EBUILD fff-20050517.ebuild 381 BLAKE2B 93c931f289a3f932baf9c46f53b377cbe120e329472220365b864d742ed1c957e3e5beb3e971c6cca6f29bb68ab6ad3cfbf3f99501a61296f5a1b7909f66b8fa SHA512 4da75faf1356b84950939c33e901e4a9b485a7991595389c389128a2996fedb6168dcc8725334e0b1bec8919651d57c0413d89a849f99c9ff14bd87ecc436ab9
+MISC metadata.xml 721 BLAKE2B 24ef6c184690e15233758f7c36f2845d662ab56426bce3cf6cc5ad1cdb71b0eaf8393e4469de00090a56fad7b4fb583ee3055dd77027e930e539e934601941d2 SHA512 4d8a05989e3c6a661471102baf0af7df5a057b3b4662789d42c839039143ff4f85fb5f471b9e4c2a503839761c0e04baedd70307b717b797ab1861415c428cf7
diff --git a/app-emacs/fff/fff-20050517.ebuild b/app-emacs/fff/fff-20050517.ebuild
new file mode 100644
index 000000000000..a4677492657b
--- /dev/null
+++ b/app-emacs/fff/fff-20050517.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Fast file finder for Emacs"
+HOMEPAGE="http://www.splode.com/~friedman/software/emacs-lisp/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="sys-apps/mlocate"
+
+SITEFILE="50${PN}-gentoo.el"
diff --git a/app-emacs/fff/files/50fff-gentoo.el b/app-emacs/fff/files/50fff-gentoo.el
new file mode 100644
index 000000000000..84df8bdd9e8b
--- /dev/null
+++ b/app-emacs/fff/files/50fff-gentoo.el
@@ -0,0 +1,17 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'fff-find-file-in-envvar-path "fff" nil t)
+(autoload 'fff-insert-file-in-envvar-path "fff" nil t)
+(autoload 'fff-find-file-in-exec-path "fff" nil t)
+(autoload 'fff-insert-file-in-exec-path "fff" nil t)
+(autoload 'fff-find-file-in-path "fff" nil t)
+(autoload 'fff-insert-file-in-path "fff" nil t)
+(autoload 'fff-find-file-in-locate-db "fff" nil t)
+(autoload 'fff-insert-file-in-locate-db "fff" nil t)
+(autoload 'fff-install-map "fff" nil t)
+(autoload 'fff-find-emacs-lisp-library "fff-elisp" nil t)
+(autoload 'fff-insert-emacs-lisp-library "fff-elisp" nil t)
+(autoload 'fff-locate-emacs-lisp-library "fff-elisp" nil t)
+(autoload 'fff-find-loaded-elisp-function-or-variable "fff-elisp" nil t)
+(autoload 'fff-elisp-install-map "fff-elisp" nil t)
+(autoload 'fff-find-rfc "fff-rfc" nil t)
+(autoload 'fff-rfc-install-map "fff-rfc" nil t)
diff --git a/app-emacs/fff/metadata.xml b/app-emacs/fff/metadata.xml
new file mode 100644
index 000000000000..ef4d2c5a9445
--- /dev/null
+++ b/app-emacs/fff/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<longdescription>
+ This package provides several shortcut commands for visiting or
+ inserting files without having to specify them by their complete name.
+ For example, you can visit programs in your exec-path (some of which
+ may be humanly-readable shell scripts or config files), or anything
+ else which is quickly locatable via a prebuilt database or path list.
+ Completion is also available for many commands.
+</longdescription>
+<stabilize-allarches/>
+</pkgmetadata>