summaryrefslogtreecommitdiff
path: root/app-emacs/exec-path-from-shell/exec-path-from-shell-2.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/exec-path-from-shell/exec-path-from-shell-2.2.ebuild')
-rw-r--r--app-emacs/exec-path-from-shell/exec-path-from-shell-2.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-emacs/exec-path-from-shell/exec-path-from-shell-2.2.ebuild b/app-emacs/exec-path-from-shell/exec-path-from-shell-2.2.ebuild
new file mode 100644
index 000000000000..d2795541094c
--- /dev/null
+++ b/app-emacs/exec-path-from-shell/exec-path-from-shell-2.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Ensure environment variables inside Emacs are the same as in shell"
+HOMEPAGE="https://github.com/purcell/exec-path-from-shell/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/purcell/${PN}.git"
+else
+ SRC_URI="https://github.com/purcell/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}