summaryrefslogtreecommitdiff
path: root/app-emacs/evil/evil-1.0.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/evil/evil-1.0.8.ebuild')
-rw-r--r--app-emacs/evil/evil-1.0.8.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-emacs/evil/evil-1.0.8.ebuild b/app-emacs/evil/evil-1.0.8.ebuild
new file mode 100644
index 000000000000..e9a11acabe1e
--- /dev/null
+++ b/app-emacs/evil/evil-1.0.8.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Extensible vi layer for Emacs"
+HOMEPAGE="https://github.com/emacs-evil/evil"
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-3+ FDL-1.3+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+RESTRICT="test"
+
+RDEPEND=">=app-emacs/undo-tree-0.6.3"
+DEPEND="${RDEPEND}
+ sys-apps/texinfo"
+
+S="${WORKDIR}/${PN}"
+ELISP_REMOVE="evil-pkg.el evil-tests.el"
+ELISP_TEXINFO="doc/evil.texi"
+SITEFILE="50${PN}-gentoo.el"
+DOCS="CHANGES.org"