summaryrefslogtreecommitdiff
path: root/app-emacs/epl/epl-0.9-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/epl/epl-0.9-r2.ebuild')
-rw-r--r--app-emacs/epl/epl-0.9-r2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-emacs/epl/epl-0.9-r2.ebuild b/app-emacs/epl/epl-0.9-r2.ebuild
new file mode 100644
index 000000000000..377b6330fda9
--- /dev/null
+++ b/app-emacs/epl/epl-0.9-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24
+
+inherit elisp
+
+DESCRIPTION="A convenient high-level API for package.el"
+HOMEPAGE="https://github.com/cask/epl"
+SRC_URI="https://github.com/cask/epl/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( app-emacs/f )"
+
+DOCS=( README.md )
+SITEFILE="50epl-gentoo.el"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} -L . -L test -l epl.el -l test/epl-test.el \
+ -f ert-run-tests-batch-and-exit || die
+}