summaryrefslogtreecommitdiff
path: root/app-emacs/elpher/elpher-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/elpher/elpher-9999.ebuild')
-rw-r--r--app-emacs/elpher/elpher-9999.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/app-emacs/elpher/elpher-9999.ebuild b/app-emacs/elpher/elpher-9999.ebuild
index 3158f781fa81..0124c2d27c1c 100644
--- a/app-emacs/elpher/elpher-9999.ebuild
+++ b/app-emacs/elpher/elpher-9999.ebuild
@@ -10,25 +10,29 @@ inherit elisp
DESCRIPTION="Practical and friendly Gopher and Gemini client for GNU Emacs"
HOMEPAGE="https://thelambdalab.xyz/elpher/"
-if [[ ${PV} == *9999* ]] ; then
+if [[ "${PV}" == *9999* ]] ; then
inherit git-r3
+
EGIT_REPO_URI="git://thelambdalab.xyz/${PN}.git"
else
- if [[ ${PV} == 3.4.2 ]] ; then
- COMMIT=f117f2f
+ if [[ "${PV}" == 3.6.0 ]] ; then
+ COMMIT=56bc74e
SRC_URI="https://thelambdalab.xyz/gitweb/index.cgi?p=${PN}.git;a=snapshot;h=${COMMIT};sf=tgz
-> ${P}.tar.gz"
- S="${WORKDIR}"/${PN}-${COMMIT}
+ S="${WORKDIR}/${PN}-${COMMIT}"
else
die "could not generate SRC_URI"
fi
+
KEYWORDS="~amd64 ~x86"
fi
LICENSE="GPL-3+"
SLOT="0"
-ELISP_REMOVE="elpher-pkg.el"
+ELISP_REMOVE="
+ elpher-pkg.el
+"
DOCS=( ISSUES.org README )
ELISP_TEXINFO="${PN}.texi"