summaryrefslogtreecommitdiff
path: root/app-emacs/eglot/eglot-1.6-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/eglot/eglot-1.6-r1.ebuild')
-rw-r--r--app-emacs/eglot/eglot-1.6-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-emacs/eglot/eglot-1.6-r1.ebuild b/app-emacs/eglot/eglot-1.6-r1.ebuild
new file mode 100644
index 000000000000..b5463a817ab2
--- /dev/null
+++ b/app-emacs/eglot/eglot-1.6-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS="26.1"
+
+inherit elisp
+
+DESCRIPTION="A minimal Emacs LSP client"
+HOMEPAGE="https://github.com/joaotavora/eglot"
+SRC_URI="https://github.com/joaotavora/eglot/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+# test requires internet connection to install several language servers, one of which
+# is not packaged
+RESTRICT="test"
+
+SITEFILE="50${PN}-gentoo.el"
+ELISP_REMOVE="eglot-tests.el"
+DOCS=( README.md NEWS.md )
+
+src_install() {
+ elisp-make-autoload-file "${S}"/${PN}-autoload.el "${S}"/
+ elisp_src_install
+}