summaryrefslogtreecommitdiff
path: root/app-emacs/ecukes/ecukes-0.6.18-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/ecukes/ecukes-0.6.18-r1.ebuild')
-rw-r--r--app-emacs/ecukes/ecukes-0.6.18-r1.ebuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/app-emacs/ecukes/ecukes-0.6.18-r1.ebuild b/app-emacs/ecukes/ecukes-0.6.18-r1.ebuild
index 8366226926fb..56706c2cc009 100644
--- a/app-emacs/ecukes/ecukes-0.6.18-r1.ebuild
+++ b/app-emacs/ecukes/ecukes-0.6.18-r1.ebuild
@@ -34,10 +34,17 @@ BDEPEND="
DOCS=( README.markdown )
PATCHES=( "${FILESDIR}"/${PN}-bin-launcher-fix.patch )
-# Remove pkg file and failing tests
-ELISP_REMOVE="${PN}-pkg.el test/${PN}-parse-line-test.el"
+# Remove pkg file and failing tests.
+ELISP_REMOVE="
+ ${PN}-pkg.el
+ test/${PN}-parse-line-test.el
+ test/${PN}-run-test.el
+ test/${PN}-steps-test.el
+"
SITEFILE="50${PN}-gentoo.el"
+elisp-enable-tests ert-runner test
+
src_prepare() {
elisp_src_prepare
@@ -49,13 +56,10 @@ src_compile() {
elisp-compile reporters/*.el
}
-src_test() {
- ert-runner --reporter ert+duration --script || die
-}
-
src_install() {
elisp_src_install
elisp-install ${PN}/reporters reporters/*.el{,c}
- dobin bin/${PN}
+ exeinto /usr/bin
+ doexe bin/${PN}
}