summaryrefslogtreecommitdiff
path: root/app-emacs/desktop-entry-mode/desktop-entry-mode-0.27-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/desktop-entry-mode/desktop-entry-mode-0.27-r1.ebuild')
-rw-r--r--app-emacs/desktop-entry-mode/desktop-entry-mode-0.27-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-emacs/desktop-entry-mode/desktop-entry-mode-0.27-r1.ebuild b/app-emacs/desktop-entry-mode/desktop-entry-mode-0.27-r1.ebuild
new file mode 100644
index 000000000000..ac8507423c20
--- /dev/null
+++ b/app-emacs/desktop-entry-mode/desktop-entry-mode-0.27-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="GNU Emacs mode for handling freedesktop.org desktop entry files"
+HOMEPAGE="https://gitlab.freedesktop.org/xdg/desktop-file-utils"
+SRC_URI="https://www.freedesktop.org/software/desktop-file-utils/releases/desktop-file-utils-${PV}.tar.xz"
+S="${WORKDIR}"/desktop-file-utils-${PV}/misc
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="!<dev-util/desktop-file-utils-0.27-r1[emacs(-)]"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_install() {
+ elisp_src_install
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}