summaryrefslogtreecommitdiff
path: root/app-emacs/calfw/calfw-1.6-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/calfw/calfw-1.6-r1.ebuild')
-rw-r--r--app-emacs/calfw/calfw-1.6-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-emacs/calfw/calfw-1.6-r1.ebuild b/app-emacs/calfw/calfw-1.6-r1.ebuild
new file mode 100644
index 000000000000..28efbf62a8b7
--- /dev/null
+++ b/app-emacs/calfw/calfw-1.6-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="A calendar framework for Emacs"
+HOMEPAGE="https://github.com/kiwanami/emacs-calfw"
+SRC_URI="https://github.com/kiwanami/emacs-${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="howm"
+
+RDEPEND="howm? ( app-emacs/howm )"
+BDEPEND="${RDEPEND}"
+
+S="${WORKDIR}/emacs-${PN}-${PV}"
+SITEFILE="50${PN}-gentoo.el"
+DOCS="readme.md"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-time-ranges.patch
+)
+
+src_prepare() {
+ elisp_src_prepare
+ use howm || rm calfw-howm.el || die
+}