summaryrefslogtreecommitdiff
path: root/app-emacs/assess
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/assess')
-rw-r--r--app-emacs/assess/Manifest4
-rw-r--r--app-emacs/assess/assess-0.6.ebuild33
-rw-r--r--app-emacs/assess/files/50assess-gentoo.el1
-rw-r--r--app-emacs/assess/metadata.xml24
4 files changed, 62 insertions, 0 deletions
diff --git a/app-emacs/assess/Manifest b/app-emacs/assess/Manifest
new file mode 100644
index 000000000000..20c593451ff1
--- /dev/null
+++ b/app-emacs/assess/Manifest
@@ -0,0 +1,4 @@
+AUX 50assess-gentoo.el 38 BLAKE2B e96c6cf48d1522d89450e11d339c76210c672377208b56951791b83c6ef22b2c872d313084e199dd5d7b533a99106a87dbc7f15b5ee6126f71bf5f2e84165ffa SHA512 5c00bcabe2d7cc03013dc7a54b2c653940c08098ca5646d7c73624cb1ca04376ae9dcf88a7166b1925c69f0c5d192d90f6bd790fdef8ed8c3b0f9d163c987da5
+DIST assess-0.6.tar.gz 20771 BLAKE2B 29e8f84c20575314271d9a08ed3ac93f28f1c1b5c2df2ac35e397226f4eea033210ff9b96c90a282a44c60e301f5abc38be88efc74c21a2a7fdc29340d6d43e5 SHA512 ff50731867646f07b8c6f3edd1123695d008fa5265ab8b3543cbf32a54a4a0415a91304067e0dacf53890850b56377594802c9763601616bd828316f7a8cef69
+EBUILD assess-0.6.ebuild 757 BLAKE2B e420aca0039852949fdd2878b5e253801847c5dd649d98f6d1cf96d34149976787778a1e985c6bdcc4c73b9ff2259b487a2d515b07a3e9509316b869790e6304 SHA512 ab5fd569b9aaa428171ed4a6737bbb3ef23243dafc3deeaab0e7382757de1d2f6e366f92baebd297e65108224231022e542f2d8b644c6b242e84ed859b048ecc
+MISC metadata.xml 1095 BLAKE2B e29668af7cd5fd16e5ac06dc874692b9a480561a569b70d61091eeaeb39a60d69e121b1732bd0bbde9548779f9cca5587032fd8a57f86449001e47abbd392329 SHA512 9d61d5ab2005666ae61375726527ae35b7450d04653ab2171d86da7c12e5f6844ad1311a8772e82705f56851832f9306b29b81f71c789fe438ed26194f5b351a
diff --git a/app-emacs/assess/assess-0.6.ebuild b/app-emacs/assess/assess-0.6.ebuild
new file mode 100644
index 000000000000..6d09c2dc615c
--- /dev/null
+++ b/app-emacs/assess/assess-0.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Test support functions for Emacs"
+HOMEPAGE="https://github.com/phillord/assess/"
+SRC_URI="https://github.com/phillord/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="app-emacs/m-buffer"
+BDEPEND="
+ ${RDEPEND}
+ test? ( app-emacs/load-relative )
+"
+
+DOCS=( README.md )
+
+# Remove a test helper accessing the network, luckily unnecessary
+ELISP_REMOVE="test/local-sandbox.el"
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} -L . -L test \
+ -l assess-discover -f assess-discover-run-and-exit-batch || die
+}
diff --git a/app-emacs/assess/files/50assess-gentoo.el b/app-emacs/assess/files/50assess-gentoo.el
new file mode 100644
index 000000000000..431f7e90ae73
--- /dev/null
+++ b/app-emacs/assess/files/50assess-gentoo.el
@@ -0,0 +1 @@
+(add-to-list 'load-path "@SITELISP@")
diff --git a/app-emacs/assess/metadata.xml b/app-emacs/assess/metadata.xml
new file mode 100644
index 000000000000..79e64c29fbc3
--- /dev/null
+++ b/app-emacs/assess/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ Assess provides additional support for testing Emacs packages. It provides:
+ a set of predicates for comparing strings, buffers and file contents,
+ explainer functions for all predicates giving useful output, macros for
+ creating many temporary buffers at once, and for restoring the buffer list,
+ methods for testing indentation, by comparison or "roundtripping", methods
+ for testing fontification.
+ Assess aims to be a stateless as possible, leaving Emacs unchanged whether
+ the tests succeed or fail, with respect to buffers, open files and so on;
+ this helps to keep tests independent from each other.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/phillord/assess/issues/</bugs-to>
+ <remote-id type="github">phillord/assess</remote-id>
+ </upstream>
+</pkgmetadata>