summaryrefslogtreecommitdiff
path: root/app-editors
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/Manifest.gzbin14071 -> 14077 bytes
-rw-r--r--app-editors/gedit-plugins/Manifest2
-rw-r--r--app-editors/gedit-plugins/gedit-plugins-43.1.ebuild105
-rw-r--r--app-editors/gedit/Manifest2
-rw-r--r--app-editors/gedit/gedit-43.1.ebuild90
-rw-r--r--app-editors/gnome-latex/Manifest2
-rw-r--r--app-editors/gnome-latex/gnome-latex-3.42.0.ebuild50
7 files changed, 251 insertions, 0 deletions
diff --git a/app-editors/Manifest.gz b/app-editors/Manifest.gz
index d50ddb1b2f30..ef1e70d5d047 100644
--- a/app-editors/Manifest.gz
+++ b/app-editors/Manifest.gz
Binary files differ
diff --git a/app-editors/gedit-plugins/Manifest b/app-editors/gedit-plugins/Manifest
index 3dd32b7d0d28..5ed7111ec0e2 100644
--- a/app-editors/gedit-plugins/Manifest
+++ b/app-editors/gedit-plugins/Manifest
@@ -1,3 +1,5 @@
DIST gedit-plugins-42.1.tar.xz 946368 BLAKE2B 6ee8c42d5d5214cdb9095bce71623f9486c973ade69aad91eed4ae13a1ad5ab59bcc43d30078bdb9db46527160f8bc6b183a56c255d10f8027c4ff2e603fffa6 SHA512 2e36919f7b7232e4471e2c1277c33e2f79ff513b76574cf765e451064979587c170ae003c9517d33f3b9cfce916cb7f25f9e3d0a4f6a6b203086fcfff9f265aa
+DIST gedit-plugins-43.1.tar.xz 913072 BLAKE2B ebfaa6311aac490c75339cf506a58ce60864925ebee8284d72cc4b42634696511d7060eca1b8988d574e1b17dc0e0d32cc934da3c29421339044a220ea5e854e SHA512 2aad05ce15e148121b8e0dcf59546061e448aac09f42c28cee7dfc0b3c16965716059cf147c6391f1c439ac04241e94384bf6ff8dfaa40303dfe80d8de1e2fbc
EBUILD gedit-plugins-42.1.ebuild 2704 BLAKE2B 996f031b83848d81288aaaf91a02db69e0241946234284e2b579e67e31d733c1d31adec4fe18c7cf889461a62aea62edf0aac32ed2d6ea6e36f5d0a7143b10d6 SHA512 5f14b805ddee568ff88e03f710a280ae42d1088c2432a0d63284c75d372aeabcb8101f3b859d2657cd63086eb420b2c4b8c41153503b86de9c4fbac4d0a11b45
+EBUILD gedit-plugins-43.1.ebuild 2589 BLAKE2B 182008b6d34658a69f08bb97611b6a4eea7b216310b61c29400e7fdd04dbf022073eee01c8cdae3f4a554eb4fa5e5949f378ef6e2d08a8fef9a2cd097549ce54 SHA512 1b18b73046c5e9eeb2f5dfd7b907d866b63430d0278027bf70c3bc85da0bc1c5375858df6b4fa8a8eab5973614c2f87c2322435862c5972faea2f5d948e2333f
MISC metadata.xml 596 BLAKE2B cf545e591c160fc584c5c2b1e3f5fa6a47922a958f981daa5c85f3f6c8f7eaed2a520d6265241998dfe211098f70c75a0fdfff033e55e892e5775b678ea9ef5b SHA512 0a3b9e748bc2d22ea16a694f8ebd6196d05e6652f552523bfe6fa60f1c69ab50110692cda7a59239c8f6946c06d3139a4225f1744e0dd40ccbdef3e8b396f692
diff --git a/app-editors/gedit-plugins/gedit-plugins-43.1.ebuild b/app-editors/gedit-plugins/gedit-plugins-43.1.ebuild
new file mode 100644
index 000000000000..d01deb408f2f
--- /dev/null
+++ b/app-editors/gedit-plugins/gedit-plugins-43.1.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit gnome.org gnome2-utils meson python-single-r1 vala xdg
+
+DESCRIPTION="Collection of extra plugins for the gedit Text Editor"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gedit/ThirdPartyPlugins"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+SLOT="0"
+
+IUSE="charmap git +python terminal vala"
+REQUIRED_USE="
+ charmap? ( python )
+ git? ( python )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ terminal? ( python )
+"
+
+RDEPEND="
+ >=dev-libs/libpeas-1.14.1[gtk]
+ >=app-editors/gedit-43.0
+
+ >=dev-libs/glib-2.32:2
+ >=x11-libs/gtk+-3.9:3
+ >=x11-libs/gtksourceview-4.0.2:4
+
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ app-editors/gedit[python,${PYTHON_SINGLE_USEDEP}]
+ dev-libs/libpeas[python,${PYTHON_SINGLE_USEDEP}]
+ >=dev-python/dbus-python-0.82[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[cairo,${PYTHON_USEDEP}]
+ ')
+ >=x11-libs/gtk+-3.9:3[introspection]
+ >=x11-libs/gtksourceview-4.0.2:4[introspection]
+ x11-libs/pango[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ )
+ charmap? ( >=gnome-extra/gucharmap-3:2.90[introspection] )
+ git? ( >=dev-libs/libgit2-glib-0.0.6[python] )
+ terminal? ( >=x11-libs/vte-0.52:2.91[introspection] )
+" # vte-0.52+ for feed_child API compatibility
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/libxml2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ use vala && vala_setup
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dplugin_bookmarks=true
+ $(meson_use python plugin_bracketcompletion)
+ $(meson_use charmap plugin_charmap)
+ $(meson_use python plugin_codecomment)
+ $(meson_use python plugin_colorpicker)
+ $(meson_use python plugin_colorschemer)
+ -Dplugin_drawspaces=true
+ $(meson_use git plugin_git)
+ $(meson_use python plugin_joinlines)
+ $(meson_use python plugin_multiedit)
+ $(meson_use python plugin_sessionsaver)
+ $(meson_use python plugin_smartspaces)
+ $(meson_use python plugin_synctex)
+ $(meson_use terminal plugin_terminal)
+ $(meson_use python plugin_textsize)
+ -Dplugin_wordcompletion=true
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ use python && python_optimize "${ED}/usr/$(get_libdir)/gedit/plugins/"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
diff --git a/app-editors/gedit/Manifest b/app-editors/gedit/Manifest
index 018e60536d50..140768a53750 100644
--- a/app-editors/gedit/Manifest
+++ b/app-editors/gedit/Manifest
@@ -1,3 +1,5 @@
DIST gedit-42.2.tar.xz 6917596 BLAKE2B fd7b0a1c113e944b1b3f0c2bb55a061e76e7ee71ebbfe8d64c6d5b0c7e47b8dd54519bde1b7b095a1cab27a169427eecdf35d06422c1a984f51dab82e19c7cb0 SHA512 d50f021f33764e0cdd3ac51650db0e37dacb5b6edeadddfd8136e8120e83eb740db66ada25ae43eac810896714859d6f8876640a8976ddfd6e7e602c278dcc99
+DIST gedit-43.1.tar.xz 2724084 BLAKE2B 4d0227c9287d5415298a50dda72f7997a0cb65032b9d9ac045fc2abe1a1f2a6b44cd6e36277373943cf221323ffdfeb2009fcc93ad9ef863b993bce4afac882f SHA512 00cd2f2b8ce9cc932e5b0fef7acca857d570ea73219caf031aee8a7bc6c146be6c739c01d62e4c9f4c706f025c04f7849ed88e99b996f0599314196eded54bbe
EBUILD gedit-42.2.ebuild 1882 BLAKE2B fd260e8df390c8bfc7fa296a3a90260df9de3d9b3594449ee485867eabf382bea8f2c8331800f1227bedea8f22c16d4c2c4d4eb8e70cf8e5975f3c4725f477ed SHA512 cf12494d027f6f150520ffb5d3966a2c801204d89071de3dfab4ab5c4eebb0d8300c11db80ee064df4538a0331c324a7f2041d3d89c7eadd699ac8be012c26d5
+EBUILD gedit-43.1.ebuild 1791 BLAKE2B 2980799025293991f32cc05296abb4241c19a35d3d5c5b233f4674f7f9cfced2567fc14f4312eb744a4a702b8529a082a365f541cb38c46ec72fcd029c650712 SHA512 0cd1b52d052fd70d57381b7ac3f771710fd03b206ac7200f7e7ac6da79b03953bae33ad75b54a3eb143ea8f3744103ae152a1e2b1bd1d98698a17a1175805b65
MISC metadata.xml 346 BLAKE2B 59226b3220bd9b1770fad0f5acf3b1888a57a3496f9e0a6eb0eb09c12b7a5aa461961753dd8a5a6f01db1cdb97af5b28d6a8d1d632b60f499f86e0864e29264f SHA512 3e1d83ad67b85a681b85f8fece9d6c2c3eab2f2f726447230dc1f2399a21cba211d97e11d8c06d0d1b1803fafe67be4b32c04b39c5f8586a421c525624f6697d
diff --git a/app-editors/gedit/gedit-43.1.ebuild b/app-editors/gedit/gedit-43.1.ebuild
new file mode 100644
index 000000000000..ecb7c41b1712
--- /dev/null
+++ b/app-editors/gedit/gedit-43.1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit gnome.org gnome2-utils meson python-single-r1 vala xdg
+
+DESCRIPTION="A text editor for the GNOME desktop"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gedit"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+SLOT="0"
+
+IUSE="+python gtk-doc spell"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.70:2
+ >=x11-libs/gtk+-3.22.0:3[introspection]
+ >=gui-libs/amtk-5.6:=
+ >=gui-libs/tepl-6.2:=
+ >=dev-libs/libpeas-1.14.1[gtk]
+ >=dev-libs/gobject-introspection-1.54:=
+
+ spell? ( >=app-text/gspell-0.2.5:0= )
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3:3[cairo,${PYTHON_USEDEP}]
+ dev-libs/libpeas[python,${PYTHON_SINGLE_USEDEP}]
+ ')
+ )
+
+ >=x11-libs/gtksourceview-4.0.2:4[introspection,vala]
+"
+RDEPEND="${DEPEND}
+ x11-themes/adwaita-icon-theme
+ gnome-base/gsettings-desktop-schemas
+ gnome-base/gvfs
+"
+BDEPEND="
+ $(vala_depend)
+ app-text/docbook-xml-dtd:4.1.2
+ dev-util/glib-utils
+ gtk-doc? ( >=dev-util/gtk-doc-1 )
+ dev-util/itstool
+ >=sys-devel/gettext-0.18
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ vala_setup
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use gtk-doc gtk_doc)
+ -Duser_documentation=true
+
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ if use python; then
+ python_optimize
+ python_optimize "${ED}/usr/$(get_libdir)/gedit/plugins/"
+ fi
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
diff --git a/app-editors/gnome-latex/Manifest b/app-editors/gnome-latex/Manifest
index ecb51f26e6df..7a494846daa3 100644
--- a/app-editors/gnome-latex/Manifest
+++ b/app-editors/gnome-latex/Manifest
@@ -1,3 +1,5 @@
DIST gnome-latex-3.40.0.tar.xz 1050088 BLAKE2B bd8764450ee122599fd96a7e889291805fc09d854d77aa4e7d3b01709cda8bf0c38327d05de6117a19f325ca6a61ab42e014d27b941ed8e40f0bfd963dd65680 SHA512 822d86eac81994593e71428f1c893ce7d6970bb8e98349c8ad9cc6a113e3fdb49209f1bc7f19fb8d5a22da98d7650a822c8f8ab1f5aa096e6ea0cbaf74dfafca
+DIST gnome-latex-3.42.0.tar.xz 1170904 BLAKE2B 0bd1b3c50910f70d5ef690bbc9d755a61f6e076c4a491662be77ffeb5985d50c664323c7e743d108bc65fd2c826ee12cf28076a0bfb1111cc2a922381b02034c SHA512 b36300226344eced21a694ecfa6aaef0b1e788ebbc461e0ae57adab30361bc6765c6b0136213ecf19e5b61ddbb35ac5c832fb21b6f1e7f555564bb372d5f2c7b
EBUILD gnome-latex-3.40.0.ebuild 1128 BLAKE2B 03a5c6c42afc5037644a514bd015406f373e4f134b55535d6f4d8c3ff2b421571a278d50097ab8700bd371f90a528c9b9d24a564fce33b549d4fa14f723ca653 SHA512 c1726566142ad8529b445a3fb7894587e578471d461ebd296795422d0c49349b9293e1f7fc90555077d0b276d49cfaf94b046d7e97faa7a498bd254f15d533d1
+EBUILD gnome-latex-3.42.0.ebuild 1090 BLAKE2B fd5eab1e8ae138076ed2038933a0e86edc690a3dd0718f986cbef916c74737eadafd48cc05e921c8653ffca090a2ea7ad306f4b4a81a4c51713fbdc8c2aaf607 SHA512 0dfe1706565015b6dbf5dd8d846ca1163b01f0aa568e9ebb52718da0e3e2eefba709a6b0757af005584f00c41ff65257bece2e26c335c6d9edfdfb4aa03b53bf
MISC metadata.xml 575 BLAKE2B 73604444b6c40826ddad63c484b35ed2bb7c3edf6ab59e40994881769051c96b2ebb211d47d2f67b562c48e15ca589863f6cad9984accaf40567bc8f697b15e6 SHA512 6a6bbbcd0f1e3119f624828a3f008d12377c835f4235fe6fe232f326dc8d3bcc960406d1c33ababd00b0a941f9c7160c3f6a7b106a9f70ccb505b0eb0349e5b6
diff --git a/app-editors/gnome-latex/gnome-latex-3.42.0.ebuild b/app-editors/gnome-latex/gnome-latex-3.42.0.ebuild
new file mode 100644
index 000000000000..aa72efbcb22b
--- /dev/null
+++ b/app-editors/gnome-latex/gnome-latex-3.42.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2
+
+DESCRIPTION="Integrated LaTeX environment for GNOME"
+HOMEPAGE="https://gitlab.gnome.org/swilmet/gnome-latex"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="+introspection +latexmk rubber"
+
+DEPEND="
+ >=dev-libs/glib-2.70:2
+ >=x11-libs/gtk+-3.22:3
+ >=app-text/gspell-1.8:0=
+ >=gui-libs/amtk-5.6:=
+ >=x11-libs/gtksourceview-4.0:4
+ >=gui-libs/tepl-6.2:=
+ >=dev-libs/libgee-0.10:0.8=
+ gnome-base/gsettings-desktop-schemas
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+ introspection? ( >=dev-libs/gobject-introspection-1.30.0:= )
+ gnome-base/dconf
+"
+RDEPEND="${DEPEND}
+ virtual/latex-base
+ x11-themes/hicolor-icon-theme
+ latexmk? ( dev-tex/latexmk )
+ rubber? ( dev-tex/rubber )
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.14
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.6:0
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ --enable-dconf_migration \
+ --enable-vala=no
+}