summaryrefslogtreecommitdiff
path: root/app-editors/zile/zile-2.4.14.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/zile/zile-2.4.14.ebuild')
-rw-r--r--app-editors/zile/zile-2.4.14.ebuild22
1 files changed, 20 insertions, 2 deletions
diff --git a/app-editors/zile/zile-2.4.14.ebuild b/app-editors/zile/zile-2.4.14.ebuild
index 74d312cf2c51..6b6774de68e1 100644
--- a/app-editors/zile/zile-2.4.14.ebuild
+++ b/app-editors/zile/zile-2.4.14.ebuild
@@ -3,6 +3,8 @@
EAPI=6
+inherit toolchain-funcs
+
DESCRIPTION="Zile is a small Emacs clone"
HOMEPAGE="https://www.gnu.org/software/zile/"
SRC_URI="mirror://gnu/zile/${P}.tar.gz"
@@ -13,18 +15,34 @@ KEYWORDS="~alpha ~amd64 ~arm ~ppc ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux
IUSE="acl test"
RDEPEND=">=dev-libs/boehm-gc-7.2:=
- sys-libs/ncurses:0
+ sys-libs/ncurses:0=
acl? ( virtual/acl )"
DEPEND="${RDEPEND}
+ virtual/pkgconfig
test? ( dev-lang/perl )"
QA_AM_MAINTAINER_MODE=".*help2man.*" #450278
src_configure() {
+ # --without-emacs to suppress tests for GNU Emacs #630652
econf \
--docdir="${EPREFIX}"/usr/share/doc/${PF} \
- $(use_enable acl)
+ --without-emacs \
+ --disable-valgrind-tests \
+ $(use_enable acl) \
+ CURSES_LIB="$("$(tc-getPKG_CONFIG)" --libs ncurses)"
+}
+
+src_test() {
+ if tput cup 0 0 >/dev/null || tput cuu1 >/dev/null; then
+ # We have a sane terminal that can move the cursor
+ emake check
+ else
+ ewarn "Terminal type \"${TERM}\" is too stupid to run zile"
+ ewarn "Running the tests with unset TERM instead"
+ ( unset TERM; emake check )
+ fi
}
src_install() {