summaryrefslogtreecommitdiff
path: root/app-editors/vim/vim-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/vim/vim-9999.ebuild')
-rw-r--r--app-editors/vim/vim-9999.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/app-editors/vim/vim-9999.ebuild b/app-editors/vim/vim-9999.ebuild
index aa0c429fd159..3bf04b7c1478 100644
--- a/app-editors/vim/vim-9999.ebuild
+++ b/app-editors/vim/vim-9999.ebuild
@@ -23,7 +23,7 @@ HOMEPAGE="https://vim.sourceforge.io/ https://github.com/vim/vim"
SLOT="0"
LICENSE="vim"
-IUSE="X acl cscope debug gpm lua luajit minimal nls perl python racket ruby selinux tcl terminal vim-pager"
+IUSE="X acl cscope debug gpm lua luajit minimal nls perl python racket ruby selinux sound tcl terminal vim-pager"
REQUIRED_USE="
python? ( ${PYTHON_REQUIRED_USE} )
vim-pager? ( !minimal )
@@ -47,6 +47,7 @@ RDEPEND="
racket? ( dev-scheme/racket )
ruby? ( ${RUBY_DEPS} )
selinux? ( sys-libs/libselinux )
+ sound? ( media-libs/libcanberra )
tcl? ( dev-lang/tcl:0= )
X? ( x11-libs/libXt )
"
@@ -174,6 +175,7 @@ src_configure() {
myconf=(
--with-features=tiny
--disable-nls
+ --disable-canberra
--disable-acl
--enable-gui=no
--without-x
@@ -192,6 +194,7 @@ src_configure() {
myconf=(
--with-features=huge
+ $(use_enable sound canberra)
$(use_enable acl)
$(use_enable cscope)
$(use_enable gpm)