summaryrefslogtreecommitdiff
path: root/app-editors/vim/vim-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/vim/vim-9999.ebuild')
-rw-r--r--app-editors/vim/vim-9999.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/app-editors/vim/vim-9999.ebuild b/app-editors/vim/vim-9999.ebuild
index 4780f97dad96..542c71f1871f 100644
--- a/app-editors/vim/vim-9999.ebuild
+++ b/app-editors/vim/vim-9999.ebuild
@@ -2,12 +2,12 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-VIM_VERSION="8.0"
+VIM_VERSION="8.1"
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
PYTHON_REQ_USE="threads"
USE_RUBY="ruby23 ruby24 ruby25"
-inherit vim-doc flag-o-matic versionator bash-completion-r1 python-single-r1 ruby-single
+inherit vim-doc flag-o-matic bash-completion-r1 python-single-r1 ruby-single desktop
if [[ ${PV} == 9999* ]] ; then
inherit git-r3
@@ -288,6 +288,8 @@ src_install() {
fperms a+x ${vimfiles}/macros/manpager.sh
fi
+ domenu runtime/vim.desktop
+
newbashcomp "${FILESDIR}"/${PN}-completion ${PN}
# keep in sync with 'complete ... -F' list