summaryrefslogtreecommitdiff
path: root/app-editors/vim/vim-8.2.3582.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/vim/vim-8.2.3582.ebuild')
-rw-r--r--app-editors/vim/vim-8.2.3582.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/app-editors/vim/vim-8.2.3582.ebuild b/app-editors/vim/vim-8.2.3582.ebuild
index a17b74f24534..53e69aee9488 100644
--- a/app-editors/vim/vim-8.2.3582.ebuild
+++ b/app-editors/vim/vim-8.2.3582.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -320,8 +320,10 @@ src_install() {
# Fix an issue of missing defaults.vim when USE=minimal.
if use minimal ; then
- insinto ${vimfiles}
- doins runtime/defaults.vim
+ if [[ ! -f "${vimfiles}/defaults.vim" ]]; then
+ insinto ${vimfiles}
+ doins runtime/defaults.vim
+ fi
fi
domenu runtime/vim.desktop