summaryrefslogtreecommitdiff
path: root/app-editors/vim-core/vim-core-8.2.3567.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/vim-core/vim-core-8.2.3567.ebuild')
-rw-r--r--app-editors/vim-core/vim-core-8.2.3567.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/app-editors/vim-core/vim-core-8.2.3567.ebuild b/app-editors/vim-core/vim-core-8.2.3567.ebuild
index a6ac59db33c3..eda637ba36f0 100644
--- a/app-editors/vim-core/vim-core-8.2.3567.ebuild
+++ b/app-editors/vim-core/vim-core-8.2.3567.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -193,9 +193,6 @@ src_install() {
rm -rv "${ED}${vimfiles}"/{macros,print,tools,tutor} || die "rm failed"
rm -v "${ED}"/usr/bin/vimtutor || die "rm failed"
- # Delete defaults.vim to avoid conflicts with one from vim[minimal]
- rm -v "${ED}${vimfiles}"/defaults.vim || die "rm failed"
-
local keep_colors="default"
ignore=$(rm -fr "${ED}${vimfiles}"/colors/!(${keep_colors}).vim )
@@ -210,6 +207,13 @@ src_install() {
eshopts_pop
fi
+ # Delete defaults.vim to avoid conflicts with one from vim.
+ # If defaults.vim already exists in files installed from vim,
+ # do not install defaults.vim.
+ if [[ -f "${vimfiles}/defaults.vim" ]]; then
+ rm -v "${ED}${vimfiles}"/defaults.vim || die "rm failed"
+ fi
+
newbashcomp "${FILESDIR}"/xxd-completion xxd
# install gvim icon since both vim/gvim desktop files reference it