summaryrefslogtreecommitdiff
path: root/app-editors/neovim/neovim-0.4.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/neovim/neovim-0.4.3.ebuild')
-rw-r--r--app-editors/neovim/neovim-0.4.3.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/app-editors/neovim/neovim-0.4.3.ebuild b/app-editors/neovim/neovim-0.4.3.ebuild
index 0261cc8dfed1..6f27a67c108e 100644
--- a/app-editors/neovim/neovim-0.4.3.ebuild
+++ b/app-editors/neovim/neovim-0.4.3.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils eutils xdg
+inherit cmake eutils xdg
DESCRIPTION="Vim-fork focused on extensibility and agility."
HOMEPAGE="https://neovim.io"
@@ -13,7 +13,7 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/neovim/neovim.git"
else
SRC_URI="https://github.com/neovim/neovim/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="amd64 x86"
fi
LICENSE="Apache-2.0 vim"
@@ -58,7 +58,7 @@ src_prepare() {
sed -e "/^# define SYS_VIMRC_FILE/s|\$VIM|${EPREFIX}/etc/vim|" \
-i src/nvim/globals.h || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -66,11 +66,11 @@ src_configure() {
-DFEAT_TUI=$(usex tui)
-DPREFER_LUA=$(usex luajit no yes)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
# install a default configuration file
insinto /etc/vim