summaryrefslogtreecommitdiff
path: root/app-editors/neovim/files
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/neovim/files')
-rw-r--r--app-editors/neovim/files/neovim-0.9.0-cmake-release-type.patch17
-rw-r--r--app-editors/neovim/files/neovim-0.9.1-cmake-darwin.patch14
-rw-r--r--app-editors/neovim/files/sysinit.vim7
-rw-r--r--app-editors/neovim/files/sysinit.vim-r197
4 files changed, 0 insertions, 135 deletions
diff --git a/app-editors/neovim/files/neovim-0.9.0-cmake-release-type.patch b/app-editors/neovim/files/neovim-0.9.0-cmake-release-type.patch
deleted file mode 100644
index b6026437f7bf..000000000000
--- a/app-editors/neovim/files/neovim-0.9.0-cmake-release-type.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 521ef93..a637866 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -114,12 +114,6 @@ set(NVIM_API_LEVEL 11) # Bump this after any API change.
- set(NVIM_API_LEVEL_COMPAT 0) # Adjust this after a _breaking_ API change.
- set(NVIM_API_PRERELEASE false)
-
--# Default to -O2 on release builds.
--if(CMAKE_C_FLAGS_RELEASE MATCHES "-O3")
-- message(STATUS "Replacing -O3 in CMAKE_C_FLAGS_RELEASE with -O2")
-- string(REPLACE "-O3" "-O2" CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE}")
--endif()
--
- # Build-type: RelWithDebInfo
-
- # /Og means something different in MSVC
diff --git a/app-editors/neovim/files/neovim-0.9.1-cmake-darwin.patch b/app-editors/neovim/files/neovim-0.9.1-cmake-darwin.patch
deleted file mode 100644
index 1488148298bd..000000000000
--- a/app-editors/neovim/files/neovim-0.9.1-cmake-darwin.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- a/src/nvim/CMakeLists.txt
-+++ b/src/nvim/CMakeLists.txt
-@@ -415,11 +415,7 @@ foreach(gen_include ${prop})
- list(APPEND gen_cflags "-I${gen_include}")
- endforeach()
- endforeach()
-
--if(APPLE AND CMAKE_OSX_SYSROOT)
-- list(APPEND gen_cflags "-isysroot")
-- list(APPEND gen_cflags "${CMAKE_OSX_SYSROOT}")
--endif()
- set(gen_cflags ${gen_cflags} -O2)
-
- set(NVIM_VERSION_GIT_H ${PROJECT_BINARY_DIR}/cmake.config/auto/versiondef_git.h)
diff --git a/app-editors/neovim/files/sysinit.vim b/app-editors/neovim/files/sysinit.vim
index 92b802f345cf..de47eef7299e 100644
--- a/app-editors/neovim/files/sysinit.vim
+++ b/app-editors/neovim/files/sysinit.vim
@@ -55,13 +55,6 @@ augroup gentoo
" filetype and indent settings for all things Gentoo.
au BufRead,BufNewFile *.e{build,class} set ts=4 sw=4 noexpandtab
- " In text files, limit the width of text to 78 characters, but be careful
- " that we don't override the user's setting.
- autocmd BufNewFile,BufRead *.txt
- \ if &tw == 0 && ! exists("g:leave_my_textwidth_alone") |
- \ setlocal textwidth=78 |
- \ endif
-
" When editing a file, always jump to the last cursor position
autocmd BufReadPost *
\ if ! exists("g:leave_my_cursor_position_alone") |
diff --git a/app-editors/neovim/files/sysinit.vim-r1 b/app-editors/neovim/files/sysinit.vim-r1
deleted file mode 100644
index de47eef7299e..000000000000
--- a/app-editors/neovim/files/sysinit.vim-r1
+++ /dev/null
@@ -1,97 +0,0 @@
-" Default Gentoo configuration file for neovim
-" Based on the default vimrc shipped by Gentoo with app-editors/vim-core
-
-" You can override any of these settings on a global basis via the
-" "/etc/vim/nvimrc.local" file, and on a per-user basis via "~/.nvimrc".
-" You may need to create these.
-
-" Neovim comes with sensible defaults, see:
-" https://github.com/neovim/neovim/issues/2676
-" Most of the general settings from Gentoo's vimrc have been dropped here.
-" We add only some necessary fixes and a few Gentoo specific settings.
-
-" {{{ Locale settings
-" If we have a BOM, always honour that rather than trying to guess.
-if &fileencodings !~? "ucs-bom"
- set fileencodings^=ucs-bom
-endif
-
-" Always check for UTF-8 when trying to determine encodings.
-if &fileencodings !~? "utf-8"
- " If we have to add this, the default encoding is not Unicode.
- let g:added_fenc_utf8 = 1
- set fileencodings+=utf-8
-endif
-" }}}
-
-" {{{ Fix &shell, see bug #101665.
-if "" == &shell
- if executable("/bin/bash")
- set shell=/bin/bash
- elseif executable("/bin/sh")
- set shell=/bin/sh
- endif
-endif
-"}}}
-
-" {{{ Our default /bin/sh is bash, not ksh, so syntax highlighting for .sh
-" files should default to bash. See :help sh-syntax and bug #101819.
-if has("eval")
- let is_bash=1
-endif
-" }}}
-
-" {{{ Autocommands
-if has("autocmd")
-
-augroup gentoo
- au!
-
- " Gentoo-specific settings for ebuilds. These are the federally-mandated
- " required tab settings. See the following for more information:
- " http://www.gentoo.org/proj/en/devrel/handbook/handbook.xml
- " Note that the rules below are very minimal and don't cover everything.
- " Better to emerge app-vim/gentoo-syntax, which provides full syntax,
- " filetype and indent settings for all things Gentoo.
- au BufRead,BufNewFile *.e{build,class} set ts=4 sw=4 noexpandtab
-
- " When editing a file, always jump to the last cursor position
- autocmd BufReadPost *
- \ if ! exists("g:leave_my_cursor_position_alone") |
- \ if line("'\"") > 0 && line ("'\"") <= line("$") |
- \ exe "normal g'\"" |
- \ endif |
- \ endif
-
- " When editing a crontab file, set backupcopy to yes rather than auto. See
- " :help crontab and bug #53437.
- autocmd FileType crontab set backupcopy=yes
-
- " If we previously detected that the default encoding is not UTF-8
- " (g:added_fenc_utf8), assume that a file with only ASCII characters (or no
- " characters at all) isn't a Unicode file, but is in the default encoding.
- " Except of course if a byte-order mark is in effect.
- autocmd BufReadPost *
- \ if exists("g:added_fenc_utf8") && &fileencoding == "utf-8" &&
- \ ! &bomb && search('[\x80-\xFF]','nw') == 0 && &modifiable |
- \ set fileencoding= |
- \ endif
-
- " Strip trailing spaces on write
- autocmd BufWritePre *.e{build,class}
- \ if ! exists("g:leave_my_trailing_space_alone") |
- \ :%s/\s\+$//e |
- \ endif
-
-augroup END
-
-endif " has("autocmd")
-" }}}
-
-" {{{ nvimrc.local
-if filereadable("/etc/vim/nvimrc.local")
- source /etc/vim/nvimrc.local
-endif
-" }}}
-
-" vim: set tw=80 sw=2 sts=2 et foldmethod=marker :