summaryrefslogtreecommitdiff
path: root/app-editors/neovim/files/neovim-0.9.0-cmake-darwin.patch
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/neovim/files/neovim-0.9.0-cmake-darwin.patch')
-rw-r--r--app-editors/neovim/files/neovim-0.9.0-cmake-darwin.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/app-editors/neovim/files/neovim-0.9.0-cmake-darwin.patch b/app-editors/neovim/files/neovim-0.9.0-cmake-darwin.patch
new file mode 100644
index 000000000000..cba966a4ebfa
--- /dev/null
+++ b/app-editors/neovim/files/neovim-0.9.0-cmake-darwin.patch
@@ -0,0 +1,13 @@
+--- a/src/nvim/CMakeLists.txt
++++ b/src/nvim/CMakeLists.txt
+@@ -394,10 +394,6 @@ foreach(gen_include ${prop})
+ list(APPEND gen_cflags "-I${gen_include}")
+ endforeach()
+ list(APPEND gen_cflags "-I${DEPS_PREFIX}/include")
+-if(APPLE AND CMAKE_OSX_SYSROOT)
+- list(APPEND gen_cflags "-isysroot")
+- list(APPEND gen_cflags "${CMAKE_OSX_SYSROOT}")
+-endif()
+ set(gen_cflags ${gen_cflags} -O2)
+
+ set(NVIM_VERSION_GIT_H ${PROJECT_BINARY_DIR}/cmake.config/auto/versiondef_git.h)