summaryrefslogtreecommitdiff
path: root/app-editors/juffed/juffed-0.10-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/juffed/juffed-0.10-r1.ebuild')
-rw-r--r--app-editors/juffed/juffed-0.10-r1.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/app-editors/juffed/juffed-0.10-r1.ebuild b/app-editors/juffed/juffed-0.10-r1.ebuild
deleted file mode 100644
index 66870bccf3c3..000000000000
--- a/app-editors/juffed/juffed-0.10-r1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit cmake-utils
-
-DESCRIPTION="QScintilla-based tabbed text editor with syntax highlighting"
-HOMEPAGE="http://juffed.com/en/"
-SRC_URI="mirror://sourceforge/${PN}/${P}-1054.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ppc ~ppc64 x86"
-IUSE="debug"
-
-RDEPEND="
- app-i18n/enca
- dev-qt/qtcore:4
- dev-qt/qtgui:4
- dev-qt/qtsingleapplication[qt4(+),X]
- x11-libs/qscintilla:=[qt4(-)]
-"
-DEPEND="${RDEPEND}"
-
-DOCS=( ChangeLog README )
-
-PATCHES=(
- # bug 540554
- "${FILESDIR}/0.10-link-libjuff-against-libenca.patch"
-)
-
-src_prepare() {
- cmake-utils_src_prepare
-
- sed -i -e '/set(CMAKE_CXX_FLAGS/d' CMakeLists.txt || die
-}
-
-src_configure() {
- local mycmakeargs=(
- -DUSE_SYSTEM_QTSINGLEAPPLICATION=ON
- )
- cmake-utils_src_configure
-}