summaryrefslogtreecommitdiff
path: root/app-editors/hteditor/hteditor-2.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/hteditor/hteditor-2.1.0.ebuild')
-rw-r--r--app-editors/hteditor/hteditor-2.1.0.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/app-editors/hteditor/hteditor-2.1.0.ebuild b/app-editors/hteditor/hteditor-2.1.0.ebuild
index a38ef31072d0..5e5d0e083085 100644
--- a/app-editors/hteditor/hteditor-2.1.0.ebuild
+++ b/app-editors/hteditor/hteditor-2.1.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit toolchain-funcs
+inherit autotools toolchain-funcs
MY_P=${P/editor}
@@ -27,7 +27,15 @@ DOCS=( AUTHORS ChangeLog KNOWNBUGS README TODO )
S=${WORKDIR}/${MY_P}
-PATCHES=("${FILESDIR}"/${P}-gcc-7.patch)
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc-7.patch
+ "${FILESDIR}"/${P}-tinfo.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
src_configure() {
econf \