summaryrefslogtreecommitdiff
path: root/app-editors/hexedit/hexedit-1.2.13.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/hexedit/hexedit-1.2.13.ebuild')
-rw-r--r--app-editors/hexedit/hexedit-1.2.13.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-editors/hexedit/hexedit-1.2.13.ebuild b/app-editors/hexedit/hexedit-1.2.13.ebuild
new file mode 100644
index 000000000000..6bf3c4700dec
--- /dev/null
+++ b/app-editors/hexedit/hexedit-1.2.13.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="View and edit files in hex or ASCII"
+HOMEPAGE="http://rigaux.org/hexedit.html"
+SRC_URI="http://rigaux.org/${P}.src.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+
+DEPEND="sys-libs/ncurses:="
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.2.13-tinfo.patch
+ mv configure.in configure.ac || die
+ eautoreconf
+}
+
+src_install() {
+ dobin hexedit
+ doman hexedit.1
+ dodoc Changes
+}