summaryrefslogtreecommitdiff
path: root/app-editors/hexcurse/files
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/hexcurse/files')
-rw-r--r--app-editors/hexcurse/files/1.55-gcc.patch11
-rw-r--r--app-editors/hexcurse/files/1.55-tinfo.patch13
-rw-r--r--app-editors/hexcurse/files/hexcurse-1.60.0-Werror.patch7
-rw-r--r--app-editors/hexcurse/files/hexcurse-1.60.0-tinfo.patch13
4 files changed, 44 insertions, 0 deletions
diff --git a/app-editors/hexcurse/files/1.55-gcc.patch b/app-editors/hexcurse/files/1.55-gcc.patch
new file mode 100644
index 000000000000..22b996b3437d
--- /dev/null
+++ b/app-editors/hexcurse/files/1.55-gcc.patch
@@ -0,0 +1,11 @@
+--- a/src/getopt.c
++++ b/src/getopt.c
+@@ -36,8 +36,6 @@
+ * enables hexcurse to be compiled with SGI's proprietary compiler */
+ #ifdef _SGIAPI
+ #include <alloca.h>
+-#else
+-char *alloca ();
+ #endif
+ #define __alloca alloca
+ /* end of modification */
diff --git a/app-editors/hexcurse/files/1.55-tinfo.patch b/app-editors/hexcurse/files/1.55-tinfo.patch
new file mode 100644
index 000000000000..f258c06f1cf7
--- /dev/null
+++ b/app-editors/hexcurse/files/1.55-tinfo.patch
@@ -0,0 +1,13 @@
+--- a/configure.in
++++ b/configure.in
+@@ -13,7 +13,9 @@
+
+ dnl Checks for libraries.
+ dnl Replace `main' with a function in -lncurses:
+-AC_CHECK_LIB(ncurses, initscr,,AC_CHECK_LIB(curses, initscr))
++AC_CHECK_LIB(ncurses, initscr)
++AC_SEARCH_LIBS(initscr,curses)
++AC_SEARCH_LIBS(LINES,tinfo)
+
+ dnl Checks for header files.
+ AC_HEADER_STDC
diff --git a/app-editors/hexcurse/files/hexcurse-1.60.0-Werror.patch b/app-editors/hexcurse/files/hexcurse-1.60.0-Werror.patch
new file mode 100644
index 000000000000..457574f15ac1
--- /dev/null
+++ b/app-editors/hexcurse/files/hexcurse-1.60.0-Werror.patch
@@ -0,0 +1,7 @@
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -1,3 +1,3 @@
+ bin_PROGRAMS = hexcurse
+-AM_CPPFLAGS = -I$(top_srcdir)/include -Wall -Werror -Wextra
++AM_CPPFLAGS = -I$(top_srcdir)/include -Wall -Wextra
+ hexcurse_SOURCES = file.c llist.c screen.c hexcurse.c stack.c getopt.c acceptch.c color.c
diff --git a/app-editors/hexcurse/files/hexcurse-1.60.0-tinfo.patch b/app-editors/hexcurse/files/hexcurse-1.60.0-tinfo.patch
new file mode 100644
index 000000000000..1933a22bb044
--- /dev/null
+++ b/app-editors/hexcurse/files/hexcurse-1.60.0-tinfo.patch
@@ -0,0 +1,13 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -15,7 +15,9 @@
+
+ dnl Checks for libraries.
+ dnl Replace `main' with a function in -lncurses:
+-AC_CHECK_LIB(ncurses, initscr,,[AC_CHECK_LIB(curses, initscr,,[AC_MSG_ERROR([ncurses library not found])])])
++AC_CHECK_LIB(ncurses, initscr)
++AC_SEARCH_LIBS(initscr,curses)
++AC_SEARCH_LIBS(LINES,tinfo)
+
+ dnl Checks for header files.
+ AC_HEADER_STDC