summaryrefslogtreecommitdiff
path: root/app-editors/helix/helix-24.03.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/helix/helix-24.03.ebuild')
-rw-r--r--app-editors/helix/helix-24.03.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/app-editors/helix/helix-24.03.ebuild b/app-editors/helix/helix-24.03.ebuild
index b989a0d04ed8..ae80d6841b50 100644
--- a/app-editors/helix/helix-24.03.ebuild
+++ b/app-editors/helix/helix-24.03.ebuild
@@ -290,14 +290,11 @@ S="${WORKDIR}"
LICENSE="0BSD Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD Boost-1.0 ISC MIT MPL-2.0 Unicode-DFS-2016 Unlicense ZLIB"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="+grammar"
-BDEPEND="grammar? ( dev-vcs/git )"
RDEPEND="dev-vcs/git"
QA_FLAGS_IGNORED="
usr/bin/hx
- usr/share/helix/runtime/grammars/.*\.so
"
DOCS=(
@@ -308,7 +305,7 @@ DOCS=(
)
src_compile() {
- use grammar || local -x HELIX_DISABLE_AUTO_GRAMMAR_BUILD=1
+ local -x HELIX_DISABLE_AUTO_GRAMMAR_BUILD=1
cargo_src_compile
}
@@ -316,12 +313,10 @@ src_compile() {
src_install() {
cargo_src_install --path helix-term
- rm -r runtime/grammars/.gitkeep || die
- rm -r runtime/grammars/sources || die
+ insinto /usr/share/helix/runtime
+ doins -r runtime/{queries,themes,tutor}
insinto /usr/share/helix
- doins -r runtime
-
dodoc -r "${DOCS[@]}"
doicon -s 256x256 contrib/${PN}.png
@@ -338,11 +333,16 @@ src_install() {
}
pkg_postinst() {
- einfo "The runtime files (grammars, queries, themes) have been"
+ einfo "The runtime files (queries, themes) have been"
einfo "installed in '/usr/share/helix/runtime'. The environment variable"
einfo "HELIX_RUNTIME was also installed on your system. In running shell instances"
einfo "you need to run 'source /etc/profile' to pick up the new variable"
einfo "or manually set the environment variable HELIX_RUNTIME=/usr/share/helix/runtime."
+ einfo ""
+ einfo "Grammars are not installed yet. To fetch and install them, run:"
+ einfo ""
+ einfo " hx --grammar fetch"
+ einfo " hx --grammar build"
xdg_desktop_database_update
xdg_icon_cache_update
}