summaryrefslogtreecommitdiff
path: root/app-editors/gvim/gvim-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/gvim/gvim-9999.ebuild')
-rw-r--r--app-editors/gvim/gvim-9999.ebuild23
1 files changed, 12 insertions, 11 deletions
diff --git a/app-editors/gvim/gvim-9999.ebuild b/app-editors/gvim/gvim-9999.ebuild
index 9f2b67d6fdc0..826999e81017 100644
--- a/app-editors/gvim/gvim-9999.ebuild
+++ b/app-editors/gvim/gvim-9999.ebuild
@@ -5,13 +5,13 @@ EAPI=8
# Please bump with app-editors/vim-core and app-editors/vim
-VIM_VERSION="9.0"
-VIM_PATCHES_VERSION="9.0.1000"
+VIM_VERSION="9.1"
+VIM_PATCHES_VERSION="9.0.2092"
LUA_COMPAT=( lua5-{1..4} luajit )
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
PYTHON_REQ_USE="threads(+)"
-USE_RUBY="ruby27 ruby30 ruby31"
+USE_RUBY="ruby31 ruby32"
inherit bash-completion-r1 flag-o-matic lua-single prefix python-single-r1 ruby-single toolchain-funcs vim-doc xdg-utils
@@ -21,7 +21,7 @@ if [[ ${PV} == 9999* ]]; then
EGIT_CHECKOUT_DIR=${WORKDIR}/vim-${PV}
else
SRC_URI="https://github.com/vim/vim/archive/v${PV}.tar.gz -> vim-${PV}.tar.gz
- https://gitweb.gentoo.org/proj/vim-patches.git/snapshot/vim-patches-vim-${VIM_PATCHES_VERSION}-patches.tar.bz2"
+ https://git.sr.ht/~xxc3nsoredxx/vim-patches/refs/download/vim-${VIM_PATCHES_VERSION}-patches/vim-${VIM_PATCHES_VERSION}-patches.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
fi
S="${WORKDIR}"/vim-${PV}
@@ -70,7 +70,8 @@ RDEPEND="
sound? ( media-libs/libcanberra )
tcl? ( dev-lang/tcl:0= )
"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
# configure runs the Lua interpreter
BDEPEND="
dev-build/autoconf
@@ -83,7 +84,7 @@ PDEPEND="!minimal? ( app-vim/gentoo-syntax )"
if [[ ${PV} != 9999* ]]; then
# Gentoo patches to fix runtime issues, cross-compile errors, etc
PATCHES=(
- "${WORKDIR}/vim-patches-vim-${VIM_PATCHES_VERSION}-patches"
+ "${WORKDIR}/vim-${VIM_PATCHES_VERSION}-patches"
)
fi
@@ -117,9 +118,9 @@ src_prepare() {
# Read vimrc and gvimrc from /etc/vim
echo '#define SYS_VIMRC_FILE "'${EPREFIX}'/etc/vim/vimrc"' \
- >> "${S}"/src/feature.h || die "echo failed"
+ >> "${S}"/src/feature.h || die "echo failed"
echo '#define SYS_GVIMRC_FILE "'${EPREFIX}'/etc/vim/gvimrc"' \
- >> "${S}"/src/feature.h || die "echo failed"
+ >> "${S}"/src/feature.h || die "echo failed"
# Use exuberant ctags which installs as /usr/bin/exuberant-ctags.
# Hopefully this pattern won't break for a while at least.
@@ -137,7 +138,7 @@ src_prepare() {
# which isn't even in the source file being invalid, we'll do some trickery
# to make the error never occur. bug 66162 (02 October 2004 ciaranm)
find "${S}" -name '*.c' | while read c; do
- echo >> "$c" || die "echo failed"
+ echo >> "$c" || die "echo failed"
done
# Try to avoid sandbox problems. Bug #114475.
@@ -260,7 +261,7 @@ src_configure() {
fi
econf \
- --with-modified-by=Gentoo-${PVR} \
+ --with-modified-by="Gentoo-${PVR} (RIP Bram)" \
--with-vim-name=gvim \
--with-x \
"${myconf[@]}"