summaryrefslogtreecommitdiff
path: root/app-editors/ghex
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/ghex')
-rw-r--r--app-editors/ghex/Manifest4
-rw-r--r--app-editors/ghex/ghex-46.0.ebuild66
-rw-r--r--app-editors/ghex/ghex-9999.ebuild8
3 files changed, 73 insertions, 5 deletions
diff --git a/app-editors/ghex/Manifest b/app-editors/ghex/Manifest
index f00b223658f0..4b5183d76246 100644
--- a/app-editors/ghex/Manifest
+++ b/app-editors/ghex/Manifest
@@ -1,4 +1,6 @@
DIST ghex-45.2.tar.xz 902616 BLAKE2B 24e42b6d719280ab459d0ed7b96a502df7a5502e3d6cf385c0aa73b11808e40cac6112a3e0c3a228d5363578ccb875836efd8a13d6fc6c7e8ea4fe5a76bdb9c7 SHA512 2843b23a0673457ec72bd2aad20888fbc2ca890d3d859e6c2657af24cedc6185f6e11244574b603c0e32db2f54968e6584adf2c7e5abee84521c55148f536496
+DIST ghex-46.0.tar.xz 920568 BLAKE2B fe1608faa58e36d6c6f7aa01044acbfbf21a46547f755b37cf0ad673d7c58c882512c1790c74dde0e7fd18af92d0d9a3fc6c42c687413c5811bf8fc30e937adc SHA512 7f6c26b0644c1a253eef6eded0265ffaf882fb2400d1c4c40e9cefd9291d412b1425452930269d35c110fc88e6cf994f33a0ca9e937a419885f3c1820003220d
EBUILD ghex-45.2.ebuild 1310 BLAKE2B c3ebd59b4ed6a3281087987fdb7beabb50917a36746823e6b3eb317377ec4069da7013b1807883f565abaed2900d010afa4fd2fb8fd60dea858684fec36b9f27 SHA512 22cf7e8336ce0ce5b805a3be6eac11b42a9c5bd6b541fda634bdcb41157ec6cdec4fff352fbf3d6df565174518aa0d95c89f94787ae06f09715f413fc2be551e
-EBUILD ghex-9999.ebuild 1307 BLAKE2B 8d210c314e07d649f5f56b88076e83219b5af474e160ea8a32648736a08c8f42eb200f3982829dbe723f0d0671b49e17194b311f8cd77bcb28b4840957d64bf8 SHA512 6f194dc0640f18d0e9c09eadeb824795adfee9fe1590ce056a11622b8f57d8603be1ddfa245ac830587469c7262bdbe2644d86cf01d02127435041f5f837fe5e
+EBUILD ghex-46.0.ebuild 1308 BLAKE2B fe9a046c3767dcbbffdda25548547f22c879d0dd614a3b8516671c89a997b41837b169cf7915df4b841a36f46de598514eab0c5cadc297704fcaf4fdcf0faf8b SHA512 3db440253c6dcf4e6b198891fe8ed1491890918e99b6ff69bf5116fbafad682a6cdb4bf86ad4e1e13bf2607eafa73e8d4701635e4d8a7c6251c57afc77c1dea1
+EBUILD ghex-9999.ebuild 1308 BLAKE2B fe9a046c3767dcbbffdda25548547f22c879d0dd614a3b8516671c89a997b41837b169cf7915df4b841a36f46de598514eab0c5cadc297704fcaf4fdcf0faf8b SHA512 3db440253c6dcf4e6b198891fe8ed1491890918e99b6ff69bf5116fbafad682a6cdb4bf86ad4e1e13bf2607eafa73e8d4701635e4d8a7c6251c57afc77c1dea1
MISC metadata.xml 345 BLAKE2B 4c2385371bb42d47643f2a9d48ee5ed675267f812467fa03f69151bcdbeb996602be0a3995f976b61e0c018c8d69e3dcd37392f5927bbe24942f11c23794bac4 SHA512 c3f3cc3f436137299082ccdcaa57221d1b3f490b34febfcd6ca586769b0a8c76ce11cc5b8be823c8c88b942effc0b68d9c078ba3a28594c41419830dff04fcad
diff --git a/app-editors/ghex/ghex-46.0.ebuild b/app-editors/ghex/ghex-46.0.ebuild
new file mode 100644
index 000000000000..a1bb4fdd3f75
--- /dev/null
+++ b/app-editors/ghex/ghex-46.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="GNOME hexadecimal editor"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/ghex"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/ghex.git"
+ SRC_URI=""
+else
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="GPL-2+ FDL-1.1+"
+IUSE="gtk-doc test"
+RESTRICT="!test? ( test )"
+SLOT="4"
+
+RDEPEND="
+ >=dev-libs/glib-2.68.0:2
+ >=gui-libs/gtk-4.4.0:4
+ >=gui-libs/libadwaita-1.2:1
+ dev-libs/gobject-introspection
+ !app-editors/ghex:2
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ gtk-doc? ( dev-util/gi-docgen )
+ test? (
+ dev-util/desktop-file-utils
+ dev-libs/appstream-glib
+ )
+ dev-util/gtk-update-icon-cache
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Ddocdir="${EPREFIX}"/usr/share/gtk-doc/
+ -Ddevelopment=false
+ -Dmmap-buffer-backend=true
+ -Ddirect-buffer-backend=true
+ -Dintrospection=enabled
+ $(meson_use gtk-doc gtk_doc)
+ -Dstatic-html-help=false
+ -Dvapi=false
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
diff --git a/app-editors/ghex/ghex-9999.ebuild b/app-editors/ghex/ghex-9999.ebuild
index 6bc800a0f081..a1bb4fdd3f75 100644
--- a/app-editors/ghex/ghex-9999.ebuild
+++ b/app-editors/ghex/ghex-9999.ebuild
@@ -6,14 +6,14 @@ EAPI=8
inherit gnome.org gnome2-utils meson xdg
DESCRIPTION="GNOME hexadecimal editor"
-HOMEPAGE="https://wiki.gnome.org/Apps/Ghex"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/ghex"
if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/ghex.git"
SRC_URI=""
else
- KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
fi
LICENSE="GPL-2+ FDL-1.1+"
@@ -23,8 +23,8 @@ SLOT="4"
RDEPEND="
>=dev-libs/glib-2.68.0:2
- >=gui-libs/gtk-4.4.0:4[introspection]
- gui-libs/libadwaita:1
+ >=gui-libs/gtk-4.4.0:4
+ >=gui-libs/libadwaita-1.2:1
dev-libs/gobject-introspection
!app-editors/ghex:2
"