summaryrefslogtreecommitdiff
path: root/app-editors/emacs/emacs-29.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/emacs/emacs-29.2-r1.ebuild')
-rw-r--r--app-editors/emacs/emacs-29.2-r1.ebuild18
1 files changed, 14 insertions, 4 deletions
diff --git a/app-editors/emacs/emacs-29.2-r1.ebuild b/app-editors/emacs/emacs-29.2-r1.ebuild
index 0c5599307ee4..6b943b04d393 100644
--- a/app-editors/emacs/emacs-29.2-r1.ebuild
+++ b/app-editors/emacs/emacs-29.2-r1.ebuild
@@ -450,13 +450,23 @@ src_test() {
)
use xpm || exclude_tests+=( %src/image-tests.el )
+ # Some tests hang with gnupg-2.2.42
+ local gpgver=$(best_version app-crypt/gnupg)
+ gpgver=${gpgver#*gnupg-}
+ [[ -n ${gpgver} ]] \
+ && ver_test "${gpgver}" -ge 2.2.42 && ver_test "${gpgver}" -lt 2.3 \
+ && exclude_tests+=(
+ %lisp/epg-tests.el
+ %lisp/gnus/mml-sec-tests.el
+ )
+
# Redirect GnuPG's sockets, in order not to exceed the 108 char limit
# for socket paths on Linux.
- mkdir "${T}"/gnupg || die
+ mkdir "${T}"/gpg || die
local f
- for f in S.gpg-agent{,.browser,.extra,.ssh}; do
- printf "%%Assuan%%\nsocket=%s\n" "${T}/gnupg/${f}" \
- > "test/lisp/gnus/mml-sec-resources/${f}" || die
+ for f in browser extra ssh; do
+ printf "%%Assuan%%\nsocket=%s\n" "${T}/gpg/S.${f}" \
+ > "test/lisp/gnus/mml-sec-resources/S.gpg-agent.${f}" || die
done
# See test/README for possible options