summaryrefslogtreecommitdiff
path: root/app-editors/emacs/emacs-18.59-r11.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/emacs/emacs-18.59-r11.ebuild')
-rw-r--r--app-editors/emacs/emacs-18.59-r11.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/app-editors/emacs/emacs-18.59-r11.ebuild b/app-editors/emacs/emacs-18.59-r11.ebuild
index 8b9d3d2c04e9..9b260064e0b8 100644
--- a/app-editors/emacs/emacs-18.59-r11.ebuild
+++ b/app-editors/emacs/emacs-18.59-r11.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -28,6 +28,14 @@ DEPEND="${RDEPEND}
PATCHES="../${P}-linux22x-elf-glibc21.diff ../patch"
+src_prepare() {
+ default
+
+ # Do not use the sandbox, or the dumped Emacs will be twice as large
+ sed -i -e 's:\./temacs.*dump:env SANDBOX_ON=0 LD_PRELOAD= &:' \
+ src/ymakefile || die
+}
+
src_configure() {
# autoconf? What's autoconf? We are living in 1992. ;-)
local arch
@@ -70,8 +78,7 @@ src_configure() {
}
src_compile() {
- # Do not use the sandbox, or the dumped Emacs will be twice as large
- export SANDBOX_ON=0
+ addpredict /var/lib/emacs/lock
emake --jobs=1 \
CC="$(tc-getCC)" CFLAGS="${CFLAGS} -Demacs" \
LD="$(tc-getCC) -nostdlib" LDFLAGS="${LDFLAGS}"