summaryrefslogtreecommitdiff
path: root/app-doc
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/Manifest.gzbin7838 -> 7833 bytes
-rw-r--r--app-doc/doxygen/Manifest1
-rw-r--r--app-doc/doxygen/files/doxygen-1.8.10-fix_flex_check.patch96
-rw-r--r--app-doc/pms/Manifest10
-rw-r--r--app-doc/pms/pms-9999.ebuild4
5 files changed, 6 insertions, 105 deletions
diff --git a/app-doc/Manifest.gz b/app-doc/Manifest.gz
index b168efe5999d..b96b4caf4f18 100644
--- a/app-doc/Manifest.gz
+++ b/app-doc/Manifest.gz
Binary files differ
diff --git a/app-doc/doxygen/Manifest b/app-doc/doxygen/Manifest
index 969b299ac640..3b32e71c882e 100644
--- a/app-doc/doxygen/Manifest
+++ b/app-doc/doxygen/Manifest
@@ -1,4 +1,3 @@
-AUX doxygen-1.8.10-fix_flex_check.patch 4833 BLAKE2B 8e9c600ccd526ab7375bd13fd97fda351b0e3d1efd35317a3fa423d603e05bc3e7f2663fbc85aaa4bc224d9fdfb20a5692ca0ca55dadb72db2202ba4969b38e8 SHA512 5dd35c3633d5a9e1296c7ac60e7756e0a2ee2e5c6731dfcb3a1d0460702dc96b3f9b54b6f3344fa6908c5b2b60e616f320e3505a5c97ebec43ccc613bba268a9
AUX doxygen-1.8.12-link_with_pthread.patch 1078 BLAKE2B bcf05d8e2c56e4c5a026ea8e8662e247aa48fb4c3ffeb2a26799ae98f1bbd1a9f9cfc55bcad4b9d254d6067fce8e51990ab9cecfcfa6fa9b1a9861c085525966 SHA512 01173974a66a4b6214f6506f9f9009da2ae3ee1b6f424763dfc2b1ce96293e71b463b1afb4c6ccdeac299c66132bbf6d3ee7fe543f1251ff429107f8b4017831
AUX doxygen-1.8.13-NULL-dereference.patch 867 BLAKE2B c8202a4cb59115f0e9cba80bdd3fc1283226bded40f40233a5c0a6f32adaa433c56f662f29441d60fed2a4b1633bc603102d22b56f09f45522ff3f94fdc85335 SHA512 e0dc00095d3955fd171e554d0984a3d41b02643da0fa64c0f2815cc16b8cdbf0645e848507e7f100ac6ffb0e3712ca2bbec7e1a81091177e39555bde0b5e3f12
AUX doxygen-1.8.9.1-empty-line-sigsegv.patch 489 BLAKE2B 747825ab555b28642fc607980896e3a2f71f27c739a1e2e3afca28beb37ffccf8bf7cccc0bc250a4938c84d5caa5c05d4347496dc754a4cb28b5f506a838e6c6 SHA512 8b9d70fda66eae1fd871fbf29b7587d8f3872810f4b6b7b570d8fd8711a0a0fd84257798261db2c6a7aa7efd8874cf18e1056e67f53d6ec2bd3720cfd0f572ef
diff --git a/app-doc/doxygen/files/doxygen-1.8.10-fix_flex_check.patch b/app-doc/doxygen/files/doxygen-1.8.10-fix_flex_check.patch
deleted file mode 100644
index 24a3b64ad3e1..000000000000
--- a/app-doc/doxygen/files/doxygen-1.8.10-fix_flex_check.patch
+++ /dev/null
@@ -1,96 +0,0 @@
-From 5fcb13572417a3b4a05217e9023c683864f35643 Mon Sep 17 00:00:00 2001
-From: Heiko Becker <heirecka@exherbo.org>
-Date: Thu, 19 Nov 2015 12:00:54 +0100
-Subject: [PATCH] Support flex-2.6.0
-
-The version checks only considered YY_FLEX_SUBMINOR_VERSION and did not
-take YY_FLEX_MINOR_VERSION into account, which made them fail with
-flex-2.6.0.
-
-diff --git a/src/code.l b/src/code.l
-index 3323580..25719af 100644
---- a/src/code.l
-+++ b/src/code.l
-@@ -3700,7 +3700,7 @@ void codeFreeScanner()
- extern "C" { // some bogus code to keep the compiler happy
- void codeYYdummy() { yy_flex_realloc(0,0); }
- }
--#elif YY_FLEX_SUBMINOR_VERSION<33
-+#elif YY_FLEX_MINOR_VERSION<6 && YY_FLEX_SUBMINOR_VERSION<33
- #error "You seem to be using a version of flex newer than 2.5.4 but older than 2.5.33. These versions do NOT work with doxygen! Please use version <=2.5.4 or >=2.5.33 or expect things to be parsed wrongly!"
- #endif
-
-diff --git a/src/commentscan.l b/src/commentscan.l
-index cf892a0..2629857 100644
---- a/src/commentscan.l
-+++ b/src/commentscan.l
-@@ -1128,7 +1128,7 @@ RCSTAG "$"{ID}":"[^\n$]+"$"
- // but we need to know the position in the input buffer where this
- // rule matched.
- // for flex 2.5.33+ we should use YY_CURRENT_BUFFER_LVALUE
--#if YY_FLEX_MINOR_VERSION>=5 && YY_FLEX_SUBMINOR_VERSION>=33
-+#if YY_FLEX_MINOR_VERSION>5 || YY_FLEX_MINOR_VERSION>=5 && YY_FLEX_SUBMINOR_VERSION>=33
- inputPosition=prevPosition + (int)(yy_bp - YY_CURRENT_BUFFER_LVALUE->yy_ch_buf);
- #else
- inputPosition=prevPosition + (int)(yy_bp - yy_current_buffer->yy_ch_buf);
-@@ -1190,7 +1190,7 @@ RCSTAG "$"{ID}":"[^\n$]+"$"
- g_memberGroupHeader.resize(0);
- parseMore=TRUE;
- needNewEntry = TRUE;
--#if YY_FLEX_MINOR_VERSION>=5 && YY_FLEX_SUBMINOR_VERSION>=33
-+#if YY_FLEX_MINOR_VERSION>5 || YY_FLEX_MINOR_VERSION>=5 && YY_FLEX_SUBMINOR_VERSION>=33
- inputPosition=prevPosition + (int)(yy_bp - YY_CURRENT_BUFFER_LVALUE->yy_ch_buf) + strlen(yytext);
- #else
- inputPosition=prevPosition + (int)(yy_bp - yy_current_buffer->yy_ch_buf) + strlen(yytext);
-diff --git a/src/fortrancode.l b/src/fortrancode.l
-index fb91a83..352912b 100644
---- a/src/fortrancode.l
-+++ b/src/fortrancode.l
-@@ -1306,7 +1306,7 @@ void parseFortranCode(CodeOutputInterface &od,const char *className,const QCStri
- extern "C" { // some bogus code to keep the compiler happy
- void fortrancodeYYdummy() { yy_flex_realloc(0,0); }
- }
--#elif YY_FLEX_SUBMINOR_VERSION<33
-+#elif YY_FLEX_MINOR_VERSION<6 && YY_FLEX_SUBMINOR_VERSION<33
- #error "You seem to be using a version of flex newer than 2.5.4 but older than 2.5.33. These versions do NOT work with doxygen! Please use version <=2.5.4 or >=2.5.33 or expect things to be parsed wrongly!"
- #else
- extern "C" { // some bogus code to keep the compiler happy
-diff --git a/src/pycode.l b/src/pycode.l
-index 3c41a69..f58f7c1 100644
---- a/src/pycode.l
-+++ b/src/pycode.l
-@@ -1503,7 +1503,7 @@ void parsePythonCode(CodeOutputInterface &od,const char * /*className*/,
- extern "C" { // some bogus code to keep the compiler happy
- void pycodeYYdummy() { yy_flex_realloc(0,0); }
- }
--#elif YY_FLEX_SUBMINOR_VERSION<33
-+#elif YY_FLEX_MINOR_VERSION<6 && YY_FLEX_SUBMINOR_VERSION<33
- #error "You seem to be using a version of flex newer than 2.5.4. These are currently incompatible with 2.5.4, and do NOT work with doxygen! Please use version 2.5.4 or expect things to be parsed wrongly! A bug report has been submitted (#732132)."
- #endif
-
-diff --git a/src/vhdlcode.l b/src/vhdlcode.l
-index 369ae48..6957048 100644
---- a/src/vhdlcode.l
-+++ b/src/vhdlcode.l
-@@ -1613,7 +1613,7 @@ void codeFreeVhdlScanner()
- extern "C" { // some bogus code to keep the compiler happy
- void vhdlcodeYYdummy() { yy_flex_realloc(0,0); }
- }
--#elif YY_FLEX_SUBMINOR_VERSION<33
-+#elif YY_FLEX_MINOR_VERSION<6 && YY_FLEX_SUBMINOR_VERSION<33
- #error "You seem to be using a version of flex newer than 2.5.4 but older than 2.5.33. These versions do NOT work with doxygen! Please use version <=2.5.4 or >=2.5.33 or expect things to be parsed wrongly!"
- #endif
-
-diff --git a/src/xmlcode.l b/src/xmlcode.l
-index 15b5d7e..2bef4a0 100644
---- a/src/xmlcode.l
-+++ b/src/xmlcode.l
-@@ -407,7 +407,7 @@ void resetXmlCodeParserState()
- extern "C" { // some bogus code to keep the compiler happy
- void xmlcodeYYdummy() { yy_flex_realloc(0,0); }
- }
--#elif YY_FLEX_SUBMINOR_VERSION<33
-+#elif YY_FLEX_MINOR_VERSION<6 && YY_FLEX_SUBMINOR_VERSION<33
- #error "You seem to be using a version of flex newer than 2.5.4. These are currently incompatible with 2.5.4, and do NOT work with doxygen! Please use version 2.5.4 or expect things to be parsed wrongly! A bug report has been submitted (#732132)."
- #endif
-
diff --git a/app-doc/pms/Manifest b/app-doc/pms/Manifest
index 895379af8654..3e09fe72b1f6 100644
--- a/app-doc/pms/Manifest
+++ b/app-doc/pms/Manifest
@@ -1,8 +1,8 @@
-DIST pms-5-prebuilt.tar.xz 540244 SHA256 c93ce6902db323ab7ec613ad90a6dca2beda2dd2cebcc3e8ace83c1faeb6a1c7 SHA512 64baadd65f1751783032065832d2a18242967f1853d9b6ce0565a5477c021cfad3c06d9c3cfeb83ca9a64bbb052ec67c174bfd27036945ff762fe4bbf8c28451 WHIRLPOOL 9369c7604fdf0aadb7666f1fc08f041b064896d6359dd76779dc3af842fef14d81aed07301ec52eac11462664d16faed0e3fd50a0b96702822c59538917f5f78
-DIST pms-5.tar.xz 50284 SHA256 a3b7702298adc4481584ed03f2d49e9fa7ea58638d8e8e9bf36fca832b2fbc87 SHA512 560bdda40d4d1628e97b65bb354c349e3ac52edd1e337427adb0db61e99b40d214459a5046f4b505edfabc3914e2d585ef0453b13057a25fe138b8a5ebd6292e WHIRLPOOL 373d333f1c060faacbfbd398ae3be3a0143c0ee618b093867313e4182bce7f15609445d2fc6b109f6f02fe597fe8f6cf687673029569e27fa7ed3411f4932013
-DIST pms-6_p20170429-prebuilt.tar.xz 514544 SHA256 37f6a0ae95a187a40d57ef5e7415cb0517ab7e9bc3431741fe7d5dca99e04b44 SHA512 92fd048c9e1fdf3d326d906c9d68e08bb9dae5b784117d112f24bb4131aef3f8e843cf096157e0c4eaed0d2d48e7e3bfc060ea205b04c9da0e8cbcc94b74619d WHIRLPOOL 51f05a12877651ad9e9f7cc0d8f8a4ff481d1cc781997ca65343b5226fc3fdb918c6d0eaa9bee5175ec9ae06d5acbba0798c60278966b190d8ff7424c7a5510f
-DIST pms-6_p20170429.tar.xz 53584 SHA256 34d3a449375fa89710d3c550d1f956f3f98b5726c7e729fe2208fbfc034e4df5 SHA512 b4d5eb85d1823d2c80348aa82686fcbf0ba06b19de046b722d0318e846ba6d9bbd0c810b6fe06e7d4eafd8933a1b1d2d04b041fcc35fd2496feca9c987323a5b WHIRLPOOL 452a9c2bb1e7b7fe32f1d985c16ac86690c72f1deb29cd9a22e9cee3642343282e1ebbcf99f90d5cc38a7c773035c21af2ae22223578f1d5a7c2fbe96c732a78
+DIST pms-5-prebuilt.tar.xz 540244 BLAKE2B 06fbfd4cbf9968fbe19d1960687f226c87b2a16df8b9c3c80328c9436d886b1888484b0cd636f3d5ce492578e8a3e7c1a42be5cf7f8072c71fa401f817125d33 SHA512 64baadd65f1751783032065832d2a18242967f1853d9b6ce0565a5477c021cfad3c06d9c3cfeb83ca9a64bbb052ec67c174bfd27036945ff762fe4bbf8c28451
+DIST pms-5.tar.xz 50284 BLAKE2B ecf3c34d79aa1439e0f0f4bca540b673440db04a7f533f103f5956f6a27e994ee42836ae2871c11fadf9230e2b5973d3d1db9e17167f886a6c929e533ece4d45 SHA512 560bdda40d4d1628e97b65bb354c349e3ac52edd1e337427adb0db61e99b40d214459a5046f4b505edfabc3914e2d585ef0453b13057a25fe138b8a5ebd6292e
+DIST pms-6_p20170429-prebuilt.tar.xz 514544 BLAKE2B 34f5dc9a65c9a0bcc8b6ea7c9c1e65e1fb9480b6b147f17880242aeb11e44641d4b5d59cd1ee179e3c51102af2075e28445dc8ea5cda1211d483c37007a60407 SHA512 92fd048c9e1fdf3d326d906c9d68e08bb9dae5b784117d112f24bb4131aef3f8e843cf096157e0c4eaed0d2d48e7e3bfc060ea205b04c9da0e8cbcc94b74619d
+DIST pms-6_p20170429.tar.xz 53584 BLAKE2B 3c9b7445fdd7c0a0ed2b5b6f29dd645090f0fda63f864b536e88ed5d2e0cf27bfd621da1480a576d999b1ad0b80b19ac011a5a984e8b6d24c8f7db7f68aeaa75 SHA512 b4d5eb85d1823d2c80348aa82686fcbf0ba06b19de046b722d0318e846ba6d9bbd0c810b6fe06e7d4eafd8933a1b1d2d04b041fcc35fd2496feca9c987323a5b
EBUILD pms-5_p20120920.ebuild 1466 BLAKE2B 700a3bc9defb535677c09a07253699b478621bfa059b7615ee1dd27591e04cc53ac0b1208a07b85cdf898efde3ca931d5590f4819be3f053c6e7a37e13c02518 SHA512 9d33496e8f7329c80d55e024a4cb0408487d2628eae95c2f8769478fc4b1fed465e4b8b30b46c4ca05a93d6a1fd7229620d73f3c4472b30efb383b633172b473
EBUILD pms-6_p20170429.ebuild 1597 BLAKE2B 53a85166c6b73693c1269206691c1d5894c18852f1cd54c8e79def58c1e576ac9b0bc569f382f6661f2e8cd85d4702595db5462ec080683dbb1da88d0a98bf41 SHA512 f3536cd222e766fcc64910e103006a5b0ad8864108f7f0594ff26e400b37f744eb3f71c61a83e640dee5126478422563f038318ca21535d58ed270f28b76569a
-EBUILD pms-9999.ebuild 1111 BLAKE2B e9c4efe07c241ef7bb3a465043000ca94218270eab8f0301f471e71f7d7fc1e5beb7e40085a475d8f2cc7b77f471df77e38deaccab81b5067d46e745c6e3c20d SHA512 edba51a068c080614b284b68ddf249824059fb069e97cdf6be0c83d336cd6a3adb62d6835124d669367f86cd571fddd62d6c6f40dd62285b9f84118bc981086b
+EBUILD pms-9999.ebuild 1069 BLAKE2B 52eebdd75d9e2ad8b76d9a3eab012366c0937e177e370148eef165b40a8cef3929781f18ff6fea0efc5582412425d5bb2fd6bcf66e1d608d4285ffe6906c53a6 SHA512 0d66fd71be681b73b6e9fb2a96716e1cdc03bc310efc4aadfa317a0bf2801d34bdd870c6a5f371f86c9d14ef7456e5e2fb32d5bbd47beb61083185a19bde2b34
MISC metadata.xml 495 BLAKE2B 5792a9b2db15b671aba18a6ceb77cda04e4e83ceb5ef3ac130a8180803ebad25d99c3d3bdef32bfa1f0ba9186a3b27f5110e6dc172800f75aaa177b017c738c1 SHA512 11e0668a058130a9d62d28cdd70998b1bdc21722a600d87cc76b34882eae2c82d066955fd30fed77471a7078dc2a9181483ab832549d9be4d9060f63c18820ce
diff --git a/app-doc/pms/pms-9999.ebuild b/app-doc/pms/pms-9999.ebuild
index f3e231a9274f..a33e690ba3d5 100644
--- a/app-doc/pms/pms-9999.ebuild
+++ b/app-doc/pms/pms-9999.ebuild
@@ -5,9 +5,7 @@ EAPI=6
inherit git-r3
-EGIT_REPO_URI="git://anongit.gentoo.org/proj/${PN}.git
- https://anongit.gentoo.org/git/proj/${PN}.git"
-
+EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/${PN}.git"
DESCRIPTION="Gentoo Package Manager Specification (draft)"
HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Package_Manager_Specification"