summaryrefslogtreecommitdiff
path: root/app-doc/zsh-lovers
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc/zsh-lovers')
-rw-r--r--app-doc/zsh-lovers/Manifest5
-rw-r--r--app-doc/zsh-lovers/metadata.xml11
-rw-r--r--app-doc/zsh-lovers/zsh-lovers-0.9.0.ebuild26
-rw-r--r--app-doc/zsh-lovers/zsh-lovers-0.9.1.ebuild25
4 files changed, 67 insertions, 0 deletions
diff --git a/app-doc/zsh-lovers/Manifest b/app-doc/zsh-lovers/Manifest
new file mode 100644
index 000000000000..604077a0a6f7
--- /dev/null
+++ b/app-doc/zsh-lovers/Manifest
@@ -0,0 +1,5 @@
+DIST zsh-lovers_0.9.0.tar.gz 28883 BLAKE2B a9917c2441222ea27937e4bbcfc6ed4ab7594fb406a28bbdc1849ae6dae11fd924dbf50d97b65f4800b1d3ebd044ac6b1516b80924428d007e7070817a82ced5 SHA512 54e7465304313556f9299877314f18cef631c076cad1a8f3b1ce13a6e24dcb4778e852f0eec31bce62bad2bd9503b8741238f097be8cec541e5c4c8f08af9dc4
+DIST zsh-lovers_0.9.1.tar.xz 26632 BLAKE2B b5c5015e7e61c21452b688aa46529dd468beac5a034b844185e1a497778a1c83b9d8124551a7b0dfd0d441394b0bf71fe64f4af5af7add3956c0a2a2f79f01ca SHA512 16493f2ec095fbdb992188a732ca4205880fa10fc1f1ab6cde8cbd2a0977d95bb06e46d1635c0c9910c249bec024f3cd13a1f8c6597e5201ef8a26b80fac9c2f
+EBUILD zsh-lovers-0.9.0.ebuild 786 BLAKE2B ce32b6606360d1c2da24543784d78bdcf4dafb6f3d858ac6ef5dfe6d994679e8402ce6915629f695c26f074e45266ca5623cc26739ee407ef0fe64454a9fc911 SHA512 aabcf1eed9aeb3a252d0ebe4e6a293640f172adb37461c47113aee58b81d1379734636895e8ca1abfb3b318b73d259e02ed7b07171da9ee9f9adcf3a421d5c7d
+EBUILD zsh-lovers-0.9.1.ebuild 755 BLAKE2B 9938b7bd1f902ffddff94af2841dc4445f39739624095e9fc67cb51c7dcf9d06a919d94efd3547a06ba3a5eb8c010a5773aed4ff1656e3d64a13dff24b942b16 SHA512 2335b7b932b6f1648ed3764dd8198b46f39f8943c4da4573a7ef191b75266ed3aa81be1266cf3e5233ce8ad3bd6b9eb101b3fd3f0f78f90ad29297445989af14
+MISC metadata.xml 377 BLAKE2B 6329163489737a50e5cbbf5fb0dfcd4099d97a5c675519bd86e80428aa51b89ae2c5a9329239a47a405bf6d94a61dce6f4e2acb27866ff708dc3fb4bce09d505 SHA512 b6b6d0907c374c74d7b3f3151f31ec989ce028d92df3d1d7f2e1fbabb6995ba27562d643ae7fbfd9102beb4b38fe231871eef46664e455ded7414bbfc94ceb11
diff --git a/app-doc/zsh-lovers/metadata.xml b/app-doc/zsh-lovers/metadata.xml
new file mode 100644
index 000000000000..b657b06f7239
--- /dev/null
+++ b/app-doc/zsh-lovers/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+</maintainer>
+<longdescription>
+zsh-lovers is a small project which tries to collect tips, tricks and examples for the Z shell.
+</longdescription>
+</pkgmetadata>
diff --git a/app-doc/zsh-lovers/zsh-lovers-0.9.0.ebuild b/app-doc/zsh-lovers/zsh-lovers-0.9.0.ebuild
new file mode 100644
index 000000000000..9312e8261e2a
--- /dev/null
+++ b/app-doc/zsh-lovers/zsh-lovers-0.9.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="Tips, tricks and examples for the Z shell"
+HOMEPAGE="http://grml.org/zsh/zsh-lovers.html"
+SRC_URI="http://deb.grml.org/pool/main/z/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+DEPEND="app-text/asciidoc"
+
+src_compile() {
+ asciidoc zsh-lovers.1.txt || die
+ mv zsh-lovers.1.html zsh-lovers.html || die
+ a2x -f manpage zsh-lovers.1.txt || die
+}
+
+src_install() {
+ doman zsh-lovers.1
+ dohtml zsh-lovers.html
+ dodoc README
+}
diff --git a/app-doc/zsh-lovers/zsh-lovers-0.9.1.ebuild b/app-doc/zsh-lovers/zsh-lovers-0.9.1.ebuild
new file mode 100644
index 000000000000..08c577d1925a
--- /dev/null
+++ b/app-doc/zsh-lovers/zsh-lovers-0.9.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Tips, tricks and examples for the Z shell"
+HOMEPAGE="https://grml.org/zsh/zsh-lovers.html"
+SRC_URI="https://deb.grml.org/pool/main/z/${PN}/${PN}_${PV}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+DEPEND="app-text/asciidoc"
+
+src_compile() {
+ asciidoc ${PN}.1.txt || die
+ mv ${PN}.1.html ${PN}.html || die
+ a2x -f manpage ${PN}.1.txt || die
+}
+
+src_install() {
+ doman ${PN}.1
+ dodoc ${PN}.html
+}