summaryrefslogtreecommitdiff
path: root/app-doc/doxygen/files
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc/doxygen/files')
-rw-r--r--app-doc/doxygen/files/doxygen-1.8.14-xml-c++.patch25
-rw-r--r--app-doc/doxygen/files/doxygen-1.8.15-link_with_pthread.patch32
-rw-r--r--app-doc/doxygen/files/doxygen-1.8.16-fix-external-tag-files-with-TOC.patch50
-rw-r--r--app-doc/doxygen/files/doxygen-1.8.16-ghostscript-compatilibility.patch39
4 files changed, 0 insertions, 146 deletions
diff --git a/app-doc/doxygen/files/doxygen-1.8.14-xml-c++.patch b/app-doc/doxygen/files/doxygen-1.8.14-xml-c++.patch
deleted file mode 100644
index 8680d19dd46f..000000000000
--- a/app-doc/doxygen/files/doxygen-1.8.14-xml-c++.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From f217b5c36b39a294b920437ff66055ee1a3fa5b7 Mon Sep 17 00:00:00 2001
-From: albert-github <albert.tests@gmail.com>
-Date: Tue, 19 Mar 2019 10:42:24 +0100
-Subject: [PATCH] issue #6892 xml not well-formed (invalid token) for c++
-
-the `declname` and `defname` should also be converted (compare as well the routine `generateXMLForMember`)
----
- src/xmlgen.cpp | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/xmlgen.cpp b/src/xmlgen.cpp
-index 420a653fc..568e48886 100644
---- a/src/xmlgen.cpp
-+++ b/src/xmlgen.cpp
-@@ -360,8 +360,8 @@ static void writeTemplateArgumentList(ArgumentList *al,
- }
- if (!a->name.isEmpty())
- {
-- t << indentStr << " <declname>" << a->name << "</declname>" << endl;
-- t << indentStr << " <defname>" << a->name << "</defname>" << endl;
-+ t << indentStr << " <declname>" << convertToXML(a->name) << "</declname>" << endl;
-+ t << indentStr << " <defname>" << convertToXML(a->name) << "</defname>" << endl;
- }
- if (!a->defval.isEmpty())
- {
diff --git a/app-doc/doxygen/files/doxygen-1.8.15-link_with_pthread.patch b/app-doc/doxygen/files/doxygen-1.8.15-link_with_pthread.patch
deleted file mode 100644
index 54c0a96e5e1a..000000000000
--- a/app-doc/doxygen/files/doxygen-1.8.15-link_with_pthread.patch
+++ /dev/null
@@ -1,32 +0,0 @@
---- a/addon/doxysearch/CMakeLists.txt 2019-04-03 18:43:47.995610511 +0200
-+++ b/addon/doxysearch/CMakeLists.txt 2019-04-03 18:45:27.730609191 +0200
-@@ -18,6 +18,7 @@
- ${ZLIB_LIBRARIES}
- ${WIN_EXTRA_LIBS}
- qtools
-+ pthread
- )
-
- add_executable(doxysearch.cgi
-@@ -27,6 +28,7 @@
- ${XAPIAN_LIBRARIES}
- ${ZLIB_LIBRARIES}
- ${WIN_EXTRA_LIBS}
-+ pthread
- )
-
- install(TARGETS doxyindexer doxysearch.cgi DESTINATION bin)
---- a/addon/doxywizard/CMakeLists.txt 2019-04-03 18:43:59.139610364 +0200
-+++ b/addon/doxywizard/CMakeLists.txt 2019-04-03 18:45:14.151609371 +0200
-@@ -102,9 +102,9 @@
- )
-
- if(Qt5Core_FOUND)
-- target_link_libraries(doxywizard Qt5::Core Qt5::Gui Qt5::Widgets Qt5::Xml)
-+ target_link_libraries(doxywizard Qt5::Core Qt5::Gui Qt5::Widgets Qt5::Xml pthread)
- else()
-- target_link_libraries(doxywizard ${QT_LIBRARIES} ${QT_QTMAIN_LIBRARY})
-+ target_link_libraries(doxywizard ${QT_LIBRARIES} ${QT_QTMAIN_LIBRARY} pthread)
- endif()
-
- install(TARGETS doxywizard DESTINATION bin)
diff --git a/app-doc/doxygen/files/doxygen-1.8.16-fix-external-tag-files-with-TOC.patch b/app-doc/doxygen/files/doxygen-1.8.16-fix-external-tag-files-with-TOC.patch
deleted file mode 100644
index cc0704b440f6..000000000000
--- a/app-doc/doxygen/files/doxygen-1.8.16-fix-external-tag-files-with-TOC.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-From 4a72a9b07e805b4ba27560e8e921bcee0002ef4c Mon Sep 17 00:00:00 2001
-From: albert-github <albert.tests@gmail.com>
-Date: Mon, 9 Sep 2019 13:28:28 +0200
-Subject: [PATCH] issue #7248: Including external tag files with TOC produces a
- broken index.qhp
-
-Ignore automatically generated anchor names when importing a tag file.
-
-Upstream: https://github.com/doxygen/doxygen/pull/7250
----
- src/tagreader.cpp | 19 ++++++++++++++++++-
- 1 file changed, 18 insertions(+), 1 deletion(-)
-
-diff --git a/src/tagreader.cpp b/src/tagreader.cpp
-index 56dbe7df9..d79d9b5c5 100644
---- a/src/tagreader.cpp
-+++ b/src/tagreader.cpp
-@@ -494,6 +494,23 @@ class TagFileParser : public QXmlDefaultHandler
-
- void endDocAnchor()
- {
-+ // Check whether or not the tag is automatically generate, in that case ignore the tag.
-+ switch(m_state)
-+ {
-+ case InClass:
-+ case InFile:
-+ case InNamespace:
-+ case InGroup:
-+ case InPage:
-+ case InMember:
-+ case InPackage:
-+ case InDir:
-+ if (QString(m_curString).startsWith("autotoc_md")) return;
-+ break;
-+ default:
-+ warn("Unexpected tag 'docanchor' found");
-+ return;
-+ }
- switch(m_state)
- {
- case InClass: m_curClass->docAnchors.append(new TagAnchorInfo(m_fileName,m_curString,m_title)); break;
-@@ -504,7 +521,7 @@ class TagFileParser : public QXmlDefaultHandler
- case InMember: m_curMember->docAnchors.append(new TagAnchorInfo(m_fileName,m_curString,m_title)); break;
- case InPackage: m_curPackage->docAnchors.append(new TagAnchorInfo(m_fileName,m_curString,m_title)); break;
- case InDir: m_curDir->docAnchors.append(new TagAnchorInfo(m_fileName,m_curString,m_title)); break;
-- default: warn("Unexpected tag 'docanchor' found"); break;
-+ default: warn("Unexpected tag 'docanchor' found"); break; // Not really necessary anymore
- }
- }
-
diff --git a/app-doc/doxygen/files/doxygen-1.8.16-ghostscript-compatilibility.patch b/app-doc/doxygen/files/doxygen-1.8.16-ghostscript-compatilibility.patch
deleted file mode 100644
index 55445fa19dc4..000000000000
--- a/app-doc/doxygen/files/doxygen-1.8.16-ghostscript-compatilibility.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From f08e87623368134c6541af12995b811ef9aff069 Mon Sep 17 00:00:00 2001
-From: albert-github <albert.tests@gmail.com>
-Date: Tue, 12 Nov 2019 11:42:22 +0100
-Subject: [PATCH] issue #7290 error: Problem running ghostscript gs -q -g562x56
- -r384x384x -sDEVICE=ppmraw -sOutputFile=_form0.pnm -dNOPAUSE -dBATCH --
- _form0.ps. Check your installation!
-
-@maehr had a talk with Robin Watts and Ken Sharp at IRC and there seem to be basically 3 different problems:
-* `-r%dx%d` (the dimension for `r` shouldn't be `-r384x384x`, but `-r384x384`),
-* misuse / unnecessary use of `--` and
-* since 9.50 the command needs more control access (that might be worked around by either whitelisting the file via `--permit-file-read=_form0.eps` (only works from 9.50 and upwards) or generally accepting any file with `-dNOSAFER` (works since quite some time). The second option is considered to be unsafe if we would process any file, but in this case we process self produced / controlled files. I don't know if doxygen has any threat model that it assumes. ).
-
-> Ken Sharp: Yeah the %dx is wrong, as Robin says its sheer luck that works
-the -- isn't needed and is what's causing the first problem
-and file control is the new bugbear
-
-The suggestions have been implemented and test / docs works now with old and new version.
----
- src/formula.cpp | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/src/formula.cpp b/src/formula.cpp
-index 534f56ac..3d8e6ce1 100644
---- a/src/formula.cpp
-+++ b/src/formula.cpp
-@@ -193,8 +193,8 @@ void FormulaList::generateBitmaps(const char *path)
- // used.
-
- char gsArgs[4096];
-- sprintf(gsArgs,"-q -g%dx%d -r%dx%dx -sDEVICE=ppmraw "
-- "-sOutputFile=%s.pnm -dNOPAUSE -dBATCH -- %s.ps",
-+ sprintf(gsArgs,"-q -g%dx%d -r%dx%d -sDEVICE=ppmraw "
-+ "-sOutputFile=%s.pnm -dNOPAUSE -dBATCH -dNOSAFER %s.ps",
- gx,gy,(int)(scaleFactor*72),(int)(scaleFactor*72),
- formBase.data(),formBase.data()
- );
---
-2.24.1
-