summaryrefslogtreecommitdiff
path: root/app-doc/blas-docs/blas-docs-3.1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc/blas-docs/blas-docs-3.1.1.ebuild')
-rw-r--r--app-doc/blas-docs/blas-docs-3.1.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-doc/blas-docs/blas-docs-3.1.1.ebuild b/app-doc/blas-docs/blas-docs-3.1.1.ebuild
new file mode 100644
index 000000000000..c4fe2f3edb82
--- /dev/null
+++ b/app-doc/blas-docs/blas-docs-3.1.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+DESCRIPTION="Documentation reference and man pages for blas implementations"
+HOMEPAGE="http://www.netlib.org/blas"
+SRC_URI="mirror://gentoo/lapack-man-${PV}.tgz
+ http://www.netlib.org/blas/blasqr.ps
+ http://www.netlib.org/blas/blast-forum/blas-report.ps"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+S=${WORKDIR}/lapack-${PV}/manpages
+
+src_install() {
+ # rename because doman do not yet understand manl files
+ # Not all systems have the rename command, like say FreeBSD
+ local f= t=
+ for f in blas/man/manl/*.l; do
+ t="${f%%.l}.n"
+ mv "${f}" "${t}"
+ done
+ doman blas/man/manl/*.n || die "doman failed"
+ dodoc README "${DISTDIR}"/blas{-report,qr}.ps || die "dodoc failed"
+}