summaryrefslogtreecommitdiff
path: root/app-dicts
diff options
context:
space:
mode:
Diffstat (limited to 'app-dicts')
-rw-r--r--app-dicts/Manifest.gzbin31652 -> 31652 bytes
-rw-r--r--app-dicts/myspell-en/Manifest2
-rw-r--r--app-dicts/myspell-en/myspell-en-20240601.ebuild62
3 files changed, 64 insertions, 0 deletions
diff --git a/app-dicts/Manifest.gz b/app-dicts/Manifest.gz
index 1afd6e309037..5270b195a561 100644
--- a/app-dicts/Manifest.gz
+++ b/app-dicts/Manifest.gz
Binary files differ
diff --git a/app-dicts/myspell-en/Manifest b/app-dicts/myspell-en/Manifest
index e1c99e1e7024..20fd4dddd044 100644
--- a/app-dicts/myspell-en/Manifest
+++ b/app-dicts/myspell-en/Manifest
@@ -1,5 +1,7 @@
DIST dict-en-20240201_lo.oxt 6105836 BLAKE2B 2978b36dfea07570b8be255c021e8f6cf9113f3ea342db0cc25d52e58a406f75015fdc5961556594756fde30293c21bcbf17c00b49e962e5a4f558be3f17b42c SHA512 92098925935ec23a3058db4a136e37f6dc3c24f0901de45bfd84e19efb5c3b207bb06e902368fd00c0851003b2e385719d850b3cced15e3d4a2b2d5143b5eafc
DIST dict-en-20240501_lo.oxt 6107426 BLAKE2B 811ca6f8a82f348c391b8b4df832446a8d248ec9b6ec85a9c1320f7329679e4fa6d3d507d18d3d792d878fc6f369b70135fa25a75c86b858333e370816db5761 SHA512 3d4ae13c4d68a62970742bb7e8568bebf03cbfaa04051b2152197f2d2a9fb539642a6ff6032123716c31e5f340bd2bad428983f79a7d8c6679e9da48f272e65c
+DIST dict-en-20240601_lo.oxt 6109035 BLAKE2B a90f4f2dad3a0b694aadeddf0a028138cb06f6e9f244279a43741b87260bacefd83148997f99ddca83343a301dc92a84253174e16595c11796a20dda3a372237 SHA512 688ad1a14f6a3eadbcaa7cc9e08ce6fe4bf5d6867fa92df6eb9fc91d06645936ad1844e1fa954e6c9d20aabfa8cb323a99ff9383f70c55b1afcf6685d5970b5e
EBUILD myspell-en-20240201.ebuild 1527 BLAKE2B 7117c4c52e3b4f00f2c2b9facc1c48e33ff84447cd69b30f07e1cd1cd02ea7fb8bcb2a13e2ef36275916a7f9617a465c00b17abf222b83ae6732bc2080a57d58 SHA512 a16729cee7711a1a9949be3f17beb386a43787b6f1d3404245702462023ec165076e3766f9ee35e4edcb820c5ac33ed822f42513dfde67fc1bbd1164209a1fb3
EBUILD myspell-en-20240501.ebuild 1534 BLAKE2B 99a96cb7cbe7c841a055fd070f5305e0317b6f6ccadf91986fd0c6ca1ab532a70c1dde4169961d0a49d6af8e866ff2839a99b92e55e6706ae8b53ef490e367cb SHA512 481d04acbebdfcd1d2f0481c848df8db2ebb4608fcaa8142b20d8a7819adbbfc30920cad5f9e7be2ad36b5a4d951acb815835c047f567c8aaee0c5f1a5e8b415
+EBUILD myspell-en-20240601.ebuild 1707 BLAKE2B bf65c3e67c34ec081954faf1ab3d21e95b66744182aa3ab107d38a516cdf9b2da7dc5dbd81dd8f9a5fab0440cd084fc2301e6aa61accf3eb12bf01b4a2c02508 SHA512 e234b2b0d585ea425d3f838d2b0fc93193d13a110d1580d29587c494cdbca145a9dc2ab21bf8a2a8d8a3775815b7a82f8d5196023fc7693671fbed788da9a34c
MISC metadata.xml 289 BLAKE2B 3b19ce0204dedac8876e4a00fa12dd23cadca14d8b422165467e4da65edfb91e3bb924505016333bad4ed1cb2612db674bb857f1a3dc9e1033b53dcdf20cb164 SHA512 9147be5e8b62a3de0ee8aafc33c61132f9856b28653a390be9ee7a89e3057cf06cc0b53149f08c525a6f01b2fac91e8ba6d1ed89ea46e33d8c279e76c22bec54
diff --git a/app-dicts/myspell-en/myspell-en-20240601.ebuild b/app-dicts/myspell-en/myspell-en-20240601.ebuild
new file mode 100644
index 000000000000..e2ef61695d09
--- /dev/null
+++ b/app-dicts/myspell-en/myspell-en-20240601.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit myspell-r2
+
+DESCRIPTION="English dictionaries for myspell/hunspell"
+HOMEPAGE="
+ https://extensions.libreoffice.org/extensions/english-dictionaries
+ https://github.com/marcoagpinto/aoo-mozilla-en-dict
+ https://proofingtoolgui.org
+"
+SRC_URI="https://extensions.libreoffice.org/assets/downloads/41/1717313617/dict-en-${PV}_lo.oxt"
+
+LICENSE="BSD MIT LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+PLOCALES=( "en-AU" "en-CA" "en-GB" "en-US" "en-ZA" )
+IUSE="${PLOCALES[*]/#/+l10n_}"
+REQUIRED_USE="|| ( ${PLOCALES[*]/#/l10n_} )"
+
+src_prepare() {
+ # This thesaurus is used by all the English dictionaries, see
+ # ./dictionaries.xcu in the distfile, lines 71-81.
+ MYSPELL_THES=(
+ "th_en_US_v2.dat"
+ "th_en_US_v2.idx"
+ )
+
+ local non_us_dic_used=0
+ local mylinguas
+ for lang in "${PLOCALES[@]}"; do
+ mylinguas="${lang/-/_}"
+ if use "l10n_${lang}"; then
+ MYSPELL_DICT+=( "${mylinguas}.aff" "${mylinguas}.dic" )
+ if [[ ${lang} == en-US ]]; then
+ MYSPELL_HYPH=( "hyph_en_US.dic" )
+ else
+ non_us_dic_used=1
+ fi
+ else
+ rm "README_${mylinguas}.txt" || die
+ if [[ ${lang} == "en-US" ]]; then
+ rm "README_hyph_en_US.txt" || die
+ elif [[ ${lang} == "en-GB" ]]; then
+ rm "README_en_GB_thes.txt" || die
+ fi
+ fi
+ done
+
+ if [[ non_us_dic_used -eq 1 ]]; then
+ # This is used by every English variety, except for the en-US, see
+ # ./dictionaries.xcu, lines 60-70.
+ MYSPELL_HYPH+=( "hyph_en_GB.dic" )
+ else
+ rm "README_hyph_en_GB.txt" || die
+ fi
+
+ default
+}