summaryrefslogtreecommitdiff
path: root/app-dicts/myspell-ca/myspell-ca-2.3.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-dicts/myspell-ca/myspell-ca-2.3.0.ebuild')
-rw-r--r--app-dicts/myspell-ca/myspell-ca-2.3.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-dicts/myspell-ca/myspell-ca-2.3.0.ebuild b/app-dicts/myspell-ca/myspell-ca-2.3.0.ebuild
new file mode 100644
index 000000000000..0429eda9f813
--- /dev/null
+++ b/app-dicts/myspell-ca/myspell-ca-2.3.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MYSPELL_DICT=(
+ "ca_ES.aff"
+ "ca_ES.dic"
+)
+
+MYSPELL_HYPH=(
+)
+
+MYSPELL_THES=(
+)
+
+inherit myspell-r2
+
+DESCRIPTION="Catalan dictionaries for myspell/hunspell"
+HOMEPAGE="http://www.softcatala.org/wiki/Rebost:Corrector_ortogr%C3%A0fic_de_catal%C3%A0_%28general%29_per_a_l%27OpenOffice.org"
+SRC_URI="http://www.softcatala.org/diccionaris/actualitzacions/OOo/catalan.oxt -> ${P}.oxt"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 sh sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+src_prepare() {
+ default
+ # rename to conform the common naming scheme
+ mv catalan.aff ca_ES.aff || die
+ mv catalan.dic ca_ES.dic || die
+
+ # remove licenses
+ rm -rf LICENSES-en.txt LLICENCIES-ca.txt || die
+}