summaryrefslogtreecommitdiff
path: root/app-crypt
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/Manifest.gzbin24984 -> 24981 bytes
-rw-r--r--app-crypt/libnitrokey/Manifest2
-rw-r--r--app-crypt/libnitrokey/libnitrokey-3.6.ebuild55
-rw-r--r--app-crypt/pinentry/Manifest2
-rw-r--r--app-crypt/pinentry/files/pinentry-1.2.1-automagic-capslock.patch99
-rw-r--r--app-crypt/pinentry/pinentry-1.2.1-r3.ebuild107
6 files changed, 208 insertions, 57 deletions
diff --git a/app-crypt/Manifest.gz b/app-crypt/Manifest.gz
index 39e6925505d9..242ffeb3ee16 100644
--- a/app-crypt/Manifest.gz
+++ b/app-crypt/Manifest.gz
Binary files differ
diff --git a/app-crypt/libnitrokey/Manifest b/app-crypt/libnitrokey/Manifest
index 003ad996b762..ec00150d12df 100644
--- a/app-crypt/libnitrokey/Manifest
+++ b/app-crypt/libnitrokey/Manifest
@@ -1,6 +1,4 @@
-DIST libnitrokey-3.6.tar.gz 98038 BLAKE2B 27f99e7b6de93548fc7a373f37ce784da0aa50503a5c635b4d90282e6330a5ff4c0dcc03a83a7e57045b8a1aabaab27d76a090d7c49693a6ff1037b81e75ece9 SHA512 a00a6724e5c64715eca688ec254efd979acceb5ff4cad28a205f7128e44db8674a5924634fd7da6c69d589deafca7b28b99e1d05a244c321d5cb429f2e5a3bec
DIST libnitrokey-3.8.tar.gz 118197 BLAKE2B 6216229d718e6c1763abc56cc6cea341bcc7c6e1ea1a100a490d72786e5ce88d5784c1452036835a0a2fa104254d807d135efaee4b1696508c9c9d0d865e78a1 SHA512 30f966eed77aa75057b096d18f8e88d6be28a376dfc1888e44aff80347e031a16755d30acf1bca196acc5b922778d90627ac71cba22f5cb002ba3ec058939c90
-EBUILD libnitrokey-3.6.ebuild 1110 BLAKE2B 8c675df63ba91e83e83314e079f9bc07042ac12584cc03f5c93bccc241ac97aa7ea1170e946559aa3a4426576bab7054d716530e71f12ef3839b8eadb714cb67 SHA512 f46adf94137b7b5f976fc566f48e46ccc97b791ec0dc03a6b8459f52c9f0bada878a8827a27d65c2e3240775f413ef6060a894c0ca89de078f5c26dcb305cf0b
EBUILD libnitrokey-3.8.ebuild 1105 BLAKE2B 50d2af01aa85c928e993d09831b3eb9c32afe392d64abf0635c1b0497c8b3c3958b7ceef19d5b99ab2ec8001a9446bb1ace3875f74c000584d7f518ca6b6ad58 SHA512 b9afe6976d7efa516eada71aedadce075880f96c963f28fd1d4fac8f06756605c7b4280030f6be3205f6d0018f9ae4093880cceab1268d8181896433464acb1c
EBUILD libnitrokey-9999.ebuild 1107 BLAKE2B 95f9d04299659e263f7aa811ea7fcb522dbe500c4f97ae8ad4ad8ed310d408758e869f6540a137f10ac3697f0cf4b6072ce38c475786c737681a5e0c17e7f3c6 SHA512 9e256b48a8e6497eb4dfd1da36ff99bc7b7267b4d1cd110f29b67f06b91af88aaad61865bead92eea688cf9bff79c6a33f4cd403b51ae5e70c1818976c10b677
MISC metadata.xml 398 BLAKE2B fd2f4c092ed478b034cadf189ce032a24ae41bbc908b620c98125ad340a69b79ec4c1b39a3eaae065db746e16ba5e891eb9b5f6a31967fab8261bf7fd8f5b16e SHA512 657c44fed3145300a480a6b3c4765932414d1fe0f5cc1130ffbe358502b37b46effc7f8cbef4a12b751f8f19c22d64c52a1921b7ae4d19c920e08de67f39fa2d
diff --git a/app-crypt/libnitrokey/libnitrokey-3.6.ebuild b/app-crypt/libnitrokey/libnitrokey-3.6.ebuild
deleted file mode 100644
index dd6d0126cf31..000000000000
--- a/app-crypt/libnitrokey/libnitrokey-3.6.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit udev cmake
-
-DESCRIPTION="Support library for the Nitrokey"
-HOMEPAGE="https://github.com/Nitrokey/libnitrokey"
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/Nitrokey/libnitrokey.git"
-
- # Disable pulling in bundled dependencies
- EGIT_SUBMODULES=()
-else
- SRC_URI="https://github.com/Nitrokey/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~ppc64 x86"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-libs/hidapi:=
- virtual/udev"
-DEPEND="
- ${RDEPEND}
- test? ( >=dev-cpp/catch-2.5.0:0 )"
-BDEPEND="virtual/pkgconfig"
-
-src_configure() {
- local mycmakeargs=(
- -DCMAKE_INSTALL_UDEVRULESDIR="$(get_udevdir)"/rules.d
-
- # actual hardware tests
- # 1. require a connected Nitrokey
- # 2. may kill data on your Nitrokey
- # hence the main testsuite is disabled
- -DCOMPILE_TESTS=OFF
- -DCOMPILE_OFFLINE_TESTS=$(usex test)
- )
- cmake_src_configure
-}
-
-pkg_postinst() {
- udev_reload
-}
-
-pkg_postrm() {
- udev_reload
-}
diff --git a/app-crypt/pinentry/Manifest b/app-crypt/pinentry/Manifest
index c77890dcbe80..b27ebadb34d1 100644
--- a/app-crypt/pinentry/Manifest
+++ b/app-crypt/pinentry/Manifest
@@ -1,6 +1,8 @@
AUX pinentry-1.0.0-AR.patch 326 BLAKE2B 2a05565287d2a3ff9423db1365af6ac1d2d0e0e5b3b7db49ee927eacd480cfbd29abd2313d84eb764e9d7eccd4654e2173fbf8be4508dd88f14bf12f0f9dab39 SHA512 3a8b13ddaa2af8c793586cd73e44b59828e769c3861b2d328273bac991e7e171c8714e2098674a9ae8a77c9a68098012d217e67dde8872df154a1e499837de52
+AUX pinentry-1.2.1-automagic-capslock.patch 2831 BLAKE2B abe6c6815521dd80a227704ad2698e4aaa808faccb7d95acb1b2af8bb55f2fec03d92df0b60703da2c9f092988da32572ad2fcbd1735b3109ae278d24e76e1eb SHA512 a9fe32da17d214e5d0355efa575c04f4010a42dd9b272e2446f632017a383f2dd5bd3b98a8a71fe13bf55769fa0b420310d4f3217fa16a31272058d44598f99d
DIST pinentry-1.2.1.tar.bz2 547698 BLAKE2B aa47612aa3a6f74c3676bf4018780356cb22ed4078792c1f466f9e0465199428c151c0e20dfbe6c784ef93c2b42b673daff0b6adc74c8c98fed9921e65ed42ea SHA512 a665315628f4dcf07e16a22db3f3be15d7e7e93b3deec0546c7275b71b0e3bd65535a08af5e12d6339fd6595132df86529401d9d12bd17c428a3466e8dfafab6
DIST pinentry-1.2.1.tar.bz2.sig 238 BLAKE2B 01ba3dc296a8e76c546d21d0bb0cd13778476d5d5b3ef55a3401c6a0353a56d79250d11555afb31c77c5a77e63847ded0f8eaef395bb0dc2ee3ff1d6a4ed83bd SHA512 d0e8435dc169a58f111f057f1c9fbb6c70da32a850f1107d6abdf41357c1714832728109ae61507db313d7eaef9596e5faf92fd21bed78adcc46a8c8a590430b
EBUILD pinentry-1.2.1-r1.ebuild 2125 BLAKE2B 71de119a34c46d0a1e9e26b2fdd3f7e43ed9b059e8b979e19807b6230c87e7ec1bbb3c07c3f680e7e4d824ed0658a367da1fc1f44db2d9187d4578632fc2e0b6 SHA512 70bcca087e22cee71035a70bc0c593383df7b2f52797327660bcd8a4d20d62d10d44ddb69c8ee2fcc028d601f9767bebf1764c40fc8a1b0a2a7502805aa24b07
EBUILD pinentry-1.2.1-r2.ebuild 2380 BLAKE2B 334b300075d817bedfd7b1c3f288ab76a228ee39b8a3b9680d5deb48af36edb87a69bad6cdccc21ffb1863611cf398298f9e8776f8498ba0a9d203ffc0c65d2a SHA512 c0880df7f2c706e5596bd5b4e5846795348ded0452e2a2ab2307138c07c45a20c58d71bd7126142e1d8a37def4a7fcd75086ed478eafb4fb1095ece598c3432f
+EBUILD pinentry-1.2.1-r3.ebuild 2598 BLAKE2B 972f64b83b09bf6dc7ab31bc99b298720587ca762ed1b29788162468b8f8011c399af972738da68828fc92eb413a18959dfd306b5c58a4049e2a52f3c1a78fbb SHA512 ff6e405a28a8a64f0277aa50753a4e990ce21e7042823fdf1274f4d88a81d283507ac3b81879e2fb7927484cdd6cd7cd4fa31c1f148a010f9ea60f350eb3ec54
MISC metadata.xml 344 BLAKE2B d71f184ae783d215e32dc94e346c1f753f158b298cc2df87c14d5b73454ff3b4bf0ce4744d2aa0359bc68cb993cd35d2d6f77a09769853fda5b66e1cc1da3580 SHA512 0ae1c64980d4d94b8bbc04040a17b358b7138bf4022dcd97b6d2c464bc5fac0911c9522bea253586f69c8d137b75fe3e302d7cd9802290c2720c77706d9a935f
diff --git a/app-crypt/pinentry/files/pinentry-1.2.1-automagic-capslock.patch b/app-crypt/pinentry/files/pinentry-1.2.1-automagic-capslock.patch
new file mode 100644
index 000000000000..081fad60eb03
--- /dev/null
+++ b/app-crypt/pinentry/files/pinentry-1.2.1-automagic-capslock.patch
@@ -0,0 +1,99 @@
+https://dev.gnupg.org/T6161
+https://bugs.gentoo.org/819939
+https://bugs.gentoo.org/837719
+--- a/configure.ac
++++ b/configure.ac
+@@ -508,8 +508,12 @@ fi
+ dnl
+ dnl Check for libX11 library
+ dnl
++AC_ARG_WITH(x,
++ AS_HELP_STRING([--with-x],[use libX11]),
++ [want_x11=$withval], [want_x11=maybe])
++
+ have_x11=no
+-if test "$have_w32_system" != "yes"; then
++AS_IF([test "$have_w32_system" != "yes" && test "$want_x11" != "no"], [
+ PKG_CHECK_MODULES(
+ LIBX11,
+ [x11],
+@@ -519,18 +523,20 @@ if test "$have_w32_system" != "yes"; then
+ have_x11=no
+ ]
+ )
++])
+
+- if test "$have_x11" = "yes"; then
+- AC_DEFINE(HAVE_X11, 1,
+- [The pinentries can optionally use x11.])
+- fi
+-fi
++AS_IF([test "$have_x11" = "yes"], [AC_DEFINE(HAVE_X11, 1, [The pinentries can optionally use x11.])])
+
+ dnl
+ dnl Check for KF5WaylandClient library
+ dnl
++
++AC_ARG_ENABLE(kf5-wayland,
++ AS_HELP_STRING([--enable-kf5-wayland],[use KF5WaylandClient for capslock indication on Wayland]),
++ [want_kf5_wayland=$enableval], [want_kf5_wayland=maybe])
++
+ have_kf5waylandclient=no
+-if test "$have_w32_system" != "yes"; then
++AS_IF([test "$have_w32_system" != "yes" && test "$want_kf5_wayland" != "no"], [
+ PKG_CHECK_MODULES(
+ KF5WAYLANDCLIENT,
+ [KF5WaylandClient >= 5.60],
+@@ -540,7 +546,7 @@ if test "$have_w32_system" != "yes"; then
+ have_kf5waylandclient=no
+ ]
+ )
+-fi
++])
+
+ dnl
+ dnl Check for Qt5 pinentry program.
+--- a/m4/qt.m4
++++ b/m4/qt.m4
+@@ -33,6 +33,10 @@ AC_DEFUN([FIND_QT],
+ enable_pinentry_qt5=$enableval,
+ enable_pinentry_qt5="try")
+
++ AC_ARG_ENABLE(qtx11extras,
++ AS_HELP_STRING([--enable-qtx11extras],[use Qt5X11Extras for capslock indication on X11]),
++ [want_qtx11extras=$enableval], [want_qtx11extras=maybe])
++
+ have_qt5_libs="no";
+ require_qt_cpp11="no";
+
+@@ -63,20 +67,22 @@ AC_DEFUN([FIND_QT],
+ fi
+ fi
+
+- if test "$have_x11" = "yes"; then
++ have_qt5_x11extras=no
++ AS_IF([test "$have_x11" = "yes" && test "$want_qtx11extras" != "no"], [
+ PKG_CHECK_MODULES(
+ PINENTRY_QT_X11_EXTRAS,
+ Qt5X11Extras >= 5.1.0,
+ [have_qt5_x11extras="yes"],
+- [
+- AC_MSG_WARN([pinentry-qt will be built without Caps Lock warning on X11])
+- have_qt5_x11extras="no"
+- ])
+- if test "$have_qt5_x11extras" = "yes"; then
++ [have_qt5_x11extras="no"]
++ )
++ ])
++
++ AS_IF([test "$have_qt5_x11extras" = "yes"], [
+ PINENTRY_QT_CFLAGS="$LIBX11_CFLAGS $PINENTRY_QT_CFLAGS $PINENTRY_QT_X11_EXTRAS_CFLAGS"
+ PINENTRY_QT_LIBS="$LIBX11_LIBS $PINENTRY_QT_LIBS $PINENTRY_QT_X11_EXTRAS_LIBS"
+- fi
+- fi
++ ], [
++ AC_MSG_WARN([pinentry-qt will be built without Caps Lock warning on X11])
++ ])
+
+ AC_CHECK_TOOL(MOC, moc)
+ AC_MSG_CHECKING([moc version])
diff --git a/app-crypt/pinentry/pinentry-1.2.1-r3.ebuild b/app-crypt/pinentry/pinentry-1.2.1-r3.ebuild
new file mode 100644
index 000000000000..74d0edc60322
--- /dev/null
+++ b/app-crypt/pinentry/pinentry-1.2.1-r3.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/gnupg.asc
+inherit autotools qmake-utils verify-sig
+
+DESCRIPTION="Simple passphrase entry dialogs which utilize the Assuan protocol"
+HOMEPAGE="https://gnupg.org/aegypten2"
+SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
+SRC_URI+=" verify-sig? ( mirror://gnupg/${PN}/${P}.tar.bz2.sig )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="caps efl emacs gtk keyring ncurses qt5 wayland X"
+
+DEPEND="
+ >=dev-libs/libassuan-2.1
+ >=dev-libs/libgcrypt-1.6.3
+ >=dev-libs/libgpg-error-1.17
+ efl? ( dev-libs/efl[X] )
+ keyring? ( app-crypt/libsecret )
+ ncurses? ( sys-libs/ncurses:= )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ wayland? ( kde-frameworks/kwayland:5 )
+ X? (
+ dev-qt/qtx11extras:5
+ x11-libs/libX11
+ )
+ )
+"
+RDEPEND="
+ ${DEPEND}
+ gtk? ( app-crypt/gcr:0[gtk] )
+"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+ verify-sig? ( sec-keys/openpgp-keys-gnupg )
+"
+IDEPEND=">=app-eselect/eselect-pinentry-0.7.2"
+
+DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.0-AR.patch"
+ "${FILESDIR}/${PN}-1.2.1-automagic-capslock.patch" # bug #819939, bug ##837719
+)
+
+src_prepare() {
+ default
+
+ unset FLTK_CONFIG
+
+ eautoreconf
+}
+
+src_configure() {
+ export PATH="$(qt5_get_bindir):${PATH}"
+ export QTLIB="$(qt5_get_libdir)"
+
+ local myeconfargs=(
+ $(use_enable efl pinentry-efl)
+ $(use_enable emacs pinentry-emacs)
+ $(use_enable keyring libsecret)
+ $(use_enable gtk pinentry-gnome3)
+ $(use_enable ncurses fallback-curses)
+ $(use_enable ncurses pinentry-curses)
+ $(use_enable qt5 pinentry-qt)
+ $(use_enable wayland kf5-wayland)
+ $(use_enable X qtx11extras)
+ $(use_with X x)
+
+ --enable-pinentry-tty
+ --disable-pinentry-fltk
+ --disable-pinentry-gtk2
+
+ MOC="$(qt5_get_bindir)"/moc
+ GPG_ERROR_CONFIG="${ESYSROOT}"/usr/bin/${CHOST}-gpg-error-config
+ LIBASSUAN_CONFIG="${ESYSROOT}"/usr/bin/libassuan-config
+
+ $("${S}/configure" --help | grep -- '--without-.*-prefix' | sed -e 's/^ *\([^ ]*\) .*/\1/g')
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ rm "${ED}"/usr/bin/pinentry || die
+
+ use qt5 && dosym pinentry-qt /usr/bin/pinentry-qt5
+}
+
+pkg_postinst() {
+ eselect pinentry update ifunset
+}
+
+pkg_postrm() {
+ eselect pinentry update ifunset
+}