summaryrefslogtreecommitdiff
path: root/app-crypt/yubioath-desktop
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/yubioath-desktop')
-rw-r--r--app-crypt/yubioath-desktop/Manifest3
-rw-r--r--app-crypt/yubioath-desktop/metadata.xml8
-rw-r--r--app-crypt/yubioath-desktop/yubioath-desktop-5.0.5.ebuild54
3 files changed, 65 insertions, 0 deletions
diff --git a/app-crypt/yubioath-desktop/Manifest b/app-crypt/yubioath-desktop/Manifest
new file mode 100644
index 000000000000..e7cb59530382
--- /dev/null
+++ b/app-crypt/yubioath-desktop/Manifest
@@ -0,0 +1,3 @@
+DIST yubioath-desktop-5.0.5.tar.gz 5659179 BLAKE2B 31dd1a7e9b8a5034e916f38c7893572b6b7e75fa0bc45b5b807c89010ac0e4a01a446f03d1591dd6323a015fc8fb17861fa60dc5a5e4eff40b5261fb6e3f7088 SHA512 b5a0df306916896e1fd84d6a794a43365b0e0a2cecd97ec1dacc6312507dd2e4dd55fc12b0de9d72d1d0a1b40625330373b7c74dacb2ec37a24ea3e1fd2d4ff7
+EBUILD yubioath-desktop-5.0.5.ebuild 1285 BLAKE2B 5bbf8c8394d735dbe34aff9aab5726e4dd89a880c66a2ccce6a91510d2043dca0d2b43e0e0733ea1ed6ab5452030ed3e127647143dc0190e620c385b51fccab7 SHA512 99cc4bf3068860f12950ac143c5effdf29b9f18774ad638bc352f6539ebe1d6c9da76edb7b2e996fa88e626bd6009863b2ca313553519ffcc7320cfb2ac698a0
+MISC metadata.xml 244 BLAKE2B bd2c6209566a4936a38d9109a9a533aa1669dd50701ff8a96d2a65411aa692517ab70cafd98afcad7058979d62f1a7ac796c5b99a520c0f6ca1ed92cf9e0e207 SHA512 57959095dc10704e073e5517ac49ceee80e42fb1cc3f26b1b7308f872ffda810ce42e0b80ea6da57faa7a759878a9b8d2476fe351fecac1450f9c83751802787
diff --git a/app-crypt/yubioath-desktop/metadata.xml b/app-crypt/yubioath-desktop/metadata.xml
new file mode 100644
index 000000000000..70f78a5392df
--- /dev/null
+++ b/app-crypt/yubioath-desktop/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>soap@gentoo.org</email>
+ <name>David Seifert</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-crypt/yubioath-desktop/yubioath-desktop-5.0.5.ebuild b/app-crypt/yubioath-desktop/yubioath-desktop-5.0.5.ebuild
new file mode 100644
index 000000000000..7c9e0959879c
--- /dev/null
+++ b/app-crypt/yubioath-desktop/yubioath-desktop-5.0.5.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit desktop python-single-r1 qmake-utils xdg
+
+DESCRIPTION="Library and tool for personalization of Yubico's YubiKey NEO"
+HOMEPAGE="
+ https://developers.yubico.com/yubioath-desktop/
+ https://github.com/Yubico/yubioath-desktop"
+SRC_URI="https://github.com/Yubico/yubioath-desktop/archive/${P}.tar.gz"
+S="${WORKDIR}/${PN}-${P}"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ dev-qt/qtcore:5
+ dev-qt/qtquickcontrols2:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ x11-libs/libdrm"
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '>=app-crypt/yubikey-manager-4.0.0[${PYTHON_USEDEP}]')
+ dev-python/pyotherside[${PYTHON_SINGLE_USEDEP}]"
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s:python build_qrc.py:${PYTHON} build_qrc.py:" \
+ yubioath-desktop.pro || die
+
+ python_fix_shebang "${S}"
+}
+
+src_configure() {
+ eqmake5 yubioath-desktop.pro
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+
+ domenu resources/com.yubico.yubioath.desktop
+ doicon resources/icons/com.yubico.yubioath.png
+ doicon -s scalable resources/icons/com.yubico.yubioath.svg
+}