summaryrefslogtreecommitdiff
path: root/app-crypt/yubikey-manager-qt
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/yubikey-manager-qt')
-rw-r--r--app-crypt/yubikey-manager-qt/Manifest2
-rw-r--r--app-crypt/yubikey-manager-qt/yubikey-manager-qt-1.1.4.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/app-crypt/yubikey-manager-qt/Manifest b/app-crypt/yubikey-manager-qt/Manifest
index 8810d933905e..aeb1adac06a2 100644
--- a/app-crypt/yubikey-manager-qt/Manifest
+++ b/app-crypt/yubikey-manager-qt/Manifest
@@ -1,3 +1,5 @@
DIST yubikey-manager-qt-1.1.3.tar.gz 13316325 BLAKE2B 765634b05fff9efdd5ec5e91e0a5de7f04144476b83f7b3ba8a0c8a1bc95ca7132f25e193afca2bec17fe377c683063a14657efc24fb047a64a8f4498c7abaed SHA512 84bcca3f74967ba8aa470b8dd6c8699ff6a93a85ce942934a1d0cd674a4c507ba297d9a5ebb40bae3476ea713965a7bb3816dad1110a045c338f070eb249f02b
+DIST yubikey-manager-qt-1.1.4.tar.gz 13318769 BLAKE2B 4ca85d8f9681f725cf9f8d547d850516c77a618c595814c8add12250677e495952229c966a2e59d449dfa33ac9c6788f6daa8494702137eab937b299f896e8dd SHA512 9e3e85a22d7be4e6ab30b3fd068fcc3406348d2b38f96e1ef8d693bf37edafaf8f16dc408cc9319173e871cc24d2cc4db5853ec3f8a0365221722504dc6fde04
EBUILD yubikey-manager-qt-1.1.3-r1.ebuild 1470 BLAKE2B 4a6e9ba2ed294b1ff49808fa17d6b9e06cc3be46033365a611844369f1cc571b8de1a51ce0e6199038c4628cbabef2648713a189d087a423eab2ce9933a1deec SHA512 36b25fb8a6ccca5348b4cc8627066621bff2dab4ae8f508d8d9d43dbebf48a412ca38146c6e66b29658f7cff542813ad76cef1f9d2db7ba6aba1d2c0e7527014
+EBUILD yubikey-manager-qt-1.1.4.ebuild 1470 BLAKE2B 4a6e9ba2ed294b1ff49808fa17d6b9e06cc3be46033365a611844369f1cc571b8de1a51ce0e6199038c4628cbabef2648713a189d087a423eab2ce9933a1deec SHA512 36b25fb8a6ccca5348b4cc8627066621bff2dab4ae8f508d8d9d43dbebf48a412ca38146c6e66b29658f7cff542813ad76cef1f9d2db7ba6aba1d2c0e7527014
MISC metadata.xml 371 BLAKE2B 1081e69aeb641c9d7de472bed98dfb336bc37e5374becbec4603316176419dcdb337f29b355b3395b778d250a99e32b181b84b42d4b7c10dedce7c47a6a187f6 SHA512 ed480648e967bfa3d95f71a5131963290e4265c487a345b69e34ad23c4ab18d82b08cd1e4a12f389533cc9690163fed90c05d471375fadd074c99a235105e837
diff --git a/app-crypt/yubikey-manager-qt/yubikey-manager-qt-1.1.4.ebuild b/app-crypt/yubikey-manager-qt/yubikey-manager-qt-1.1.4.ebuild
new file mode 100644
index 000000000000..6fb3d2e0e306
--- /dev/null
+++ b/app-crypt/yubikey-manager-qt/yubikey-manager-qt-1.1.4.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_6 )
+
+inherit eutils qmake-utils python-single-r1
+
+DESCRIPTION="Cross-platform application for configuring any YubiKey over all USB transports"
+HOMEPAGE="https://developers.yubico.com/yubikey-manager-qt https://github.com/Yubico/yubikey-manager-qt"
+SRC_URI="https://developers.yubico.com/${PN}/Releases/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+DEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ >=app-crypt/yubikey-manager-1.0.0[${PYTHON_MULTI_USEDEP}]
+ <app-crypt/yubikey-manager-4.0.0[${PYTHON_MULTI_USEDEP}]
+ dev-python/cryptography[${PYTHON_MULTI_USEDEP}]
+ ')
+ dev-python/pyotherside[${PYTHON_SINGLE_USEDEP}]
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgraphicaleffects:5
+ dev-qt/qtgui:5
+ dev-qt/qtquickcontrols:5[widgets]
+ dev-qt/qtquickcontrols2:5[widgets]
+ dev-qt/qtsingleapplication[qt5(+),X]
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ default
+
+ sed -i -e "s/ykman-cli//" ${PN}.pro || die
+ sed -e "/CONFIG += c++11/a CONFIG += qtsingleapplication" \
+ -i ykman-gui/ykman-gui.pro || die
+}
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+
+ domenu resources/ykman-gui.desktop
+ doicon -s 128 resources/icons/ykman.png
+ doicon -s scalable resources/icons/ykman.svg
+
+ einstalldocs
+}