summaryrefslogtreecommitdiff
path: root/app-crypt/tpm2-tools/tpm2-tools-3.1.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/tpm2-tools/tpm2-tools-3.1.3.ebuild')
-rw-r--r--app-crypt/tpm2-tools/tpm2-tools-3.1.3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-crypt/tpm2-tools/tpm2-tools-3.1.3.ebuild b/app-crypt/tpm2-tools/tpm2-tools-3.1.3.ebuild
new file mode 100644
index 000000000000..a23c0b4d9a6a
--- /dev/null
+++ b/app-crypt/tpm2-tools/tpm2-tools-3.1.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Tools for the TPM 2.0 TSS"
+HOMEPAGE="https://github.com/tpm2-software/tpm2-tools"
+SRC_URI="https://github.com/tpm2-software/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="libressl test"
+
+RDEPEND=">=app-crypt/tpm2-tss-2.0
+ net-misc/curl
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )"
+DEPEND="${RDEPEND}
+ test? ( dev-util/cmocka )"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ --disable-hardening \
+ $(use_enable test unit)
+}