summaryrefslogtreecommitdiff
path: root/app-crypt/stoken/stoken-0.91.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/stoken/stoken-0.91.ebuild')
-rw-r--r--app-crypt/stoken/stoken-0.91.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-crypt/stoken/stoken-0.91.ebuild b/app-crypt/stoken/stoken-0.91.ebuild
new file mode 100644
index 000000000000..886714165d0d
--- /dev/null
+++ b/app-crypt/stoken/stoken-0.91.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit autotools
+
+DESCRIPTION="Software Token for Linux/UNIX"
+HOMEPAGE="https://github.com/cernekee/stoken"
+SRC_URI="https://github.com/cernekee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="gtk"
+
+RDEPEND="
+ || ( dev-libs/nettle dev-libs/libtomcrypt )
+ gtk? ( >=x11-libs/gtk+-3.12:3 )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ eautoreconf
+ eapply_user
+}
+
+src_configure() {
+ econf $(use_with gtk)
+}