summaryrefslogtreecommitdiff
path: root/app-crypt/ssdeep/ssdeep-2.14.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/ssdeep/ssdeep-2.14.1.ebuild')
-rw-r--r--app-crypt/ssdeep/ssdeep-2.14.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-crypt/ssdeep/ssdeep-2.14.1.ebuild b/app-crypt/ssdeep/ssdeep-2.14.1.ebuild
new file mode 100644
index 000000000000..306ea16efa2a
--- /dev/null
+++ b/app-crypt/ssdeep/ssdeep-2.14.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="Computes context triggered piecewise hashes (fuzzy hashes)"
+HOMEPAGE="http://ssdeep.sourceforge.net/"
+SRC_URI="https://github.com/${PN}-project/${PN}/releases/download/release-${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="static-libs"
+
+DOCS=(
+ AUTHORS
+ ChangeLog
+ FILEFORMAT
+ NEWS
+ README
+ TODO
+)
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.10-shared.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" \
+ econf \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${D}" -name '*.la' -delete || die
+}