summaryrefslogtreecommitdiff
path: root/app-crypt/signify/signify-29.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/signify/signify-29.ebuild')
-rw-r--r--app-crypt/signify/signify-29.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-crypt/signify/signify-29.ebuild b/app-crypt/signify/signify-29.ebuild
new file mode 100644
index 000000000000..142c2f147c6b
--- /dev/null
+++ b/app-crypt/signify/signify-29.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="OpenBSD tool to sign and verify signatures on files"
+HOMEPAGE="http://www.openbsd.org/ https://github.com/aperezdc/signify"
+SRC_URI="https://github.com/aperezdc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-libs/libbsd-0.8"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ tc-export CC
+ default
+}
+
+src_install() {
+ dobin signify
+ doman signify.1
+}