summaryrefslogtreecommitdiff
path: root/app-crypt/shash/shash-0.2.6-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/shash/shash-0.2.6-r2.ebuild')
-rw-r--r--app-crypt/shash/shash-0.2.6-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-crypt/shash/shash-0.2.6-r2.ebuild b/app-crypt/shash/shash-0.2.6-r2.ebuild
new file mode 100644
index 000000000000..2c8f45a03e6e
--- /dev/null
+++ b/app-crypt/shash/shash-0.2.6-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit bash-completion-r1 eutils
+
+DESCRIPTION="Generate or check digests or MACs of files"
+HOMEPAGE="http://mcrypt.hellug.gr/shash/"
+SRC_URI="ftp://mcrypt.hellug.gr/pub/mcrypt/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="static"
+
+DEPEND=">=app-crypt/mhash-0.8.18-r1"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-manpage-fixes.patch
+ epatch "${FILESDIR}"/${P}-binary-files.patch
+}
+
+src_configure() {
+ econf $(use_enable static static-link)
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc AUTHORS ChangeLog INSTALL NEWS doc/sample.shashrc doc/FORMAT
+ newbashcomp "${FILESDIR}"/shash.bash-completion ${PN}
+}