summaryrefslogtreecommitdiff
path: root/app-crypt/seahorse/seahorse-41.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/seahorse/seahorse-41.0-r1.ebuild')
-rw-r--r--app-crypt/seahorse/seahorse-41.0-r1.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/app-crypt/seahorse/seahorse-41.0-r1.ebuild b/app-crypt/seahorse/seahorse-41.0-r1.ebuild
index bd31322686a1..aa0c3a9e03fe 100644
--- a/app-crypt/seahorse/seahorse-41.0-r1.ebuild
+++ b/app-crypt/seahorse/seahorse-41.0-r1.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit gnome.org gnome2-utils meson xdg vala
+PYTHON_COMPAT=( python3_{8..10} )
+inherit gnome.org gnome2-utils meson python-any-r1 xdg vala
DESCRIPTION="Manage your passwords and encryption keys"
HOMEPAGE="https://wiki.gnome.org/Apps/Seahorse"
@@ -34,6 +35,7 @@ DEPEND="${RDEPEND}
gui-libs/libhandy:1[vala]
"
BDEPEND="
+ ${PYTHON_DEPS}
app-text/docbook-xml-dtd:4.2
app-text/docbook-xsl-stylesheets
dev-libs/appstream-glib
@@ -45,9 +47,14 @@ BDEPEND="
virtual/pkgconfig
"
+PATCHES=(
+ "${FILESDIR}"/${PV}-meson-fix-gpg-version-check-for-recent-gnupg.patch
+)
+
src_prepare() {
- xdg_src_prepare
+ default
vala_src_prepare
+ gnome2_environment_reset
}
src_configure() {