summaryrefslogtreecommitdiff
path: root/app-crypt/sbctl/sbctl-0.13.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/sbctl/sbctl-0.13.ebuild')
-rw-r--r--app-crypt/sbctl/sbctl-0.13.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/app-crypt/sbctl/sbctl-0.13.ebuild b/app-crypt/sbctl/sbctl-0.13.ebuild
index 6d78f5f02945..97f67663daf4 100644
--- a/app-crypt/sbctl/sbctl-0.13.ebuild
+++ b/app-crypt/sbctl/sbctl-0.13.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2022-2023 Gentoo Authors
+# Copyright 2022-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit go-module verify-sig
+inherit go-module optfeature verify-sig
DESCRIPTION="Secure Boot key manager"
HOMEPAGE="https://github.com/Foxboron/sbctl"
@@ -31,3 +31,8 @@ src_unpack() {
src_install() {
emake PREFIX="${ED}/usr" install
}
+
+pkg_postinst() {
+ optfeature "automatically signing installed kernels with sbctl keys on each kernel installation" \
+ "sys-kernel/installkernel[systemd]"
+}