summaryrefslogtreecommitdiff
path: root/app-crypt/libnitrokey/files/libnitrokey-3.5-tests-version-gitless.patch
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/libnitrokey/files/libnitrokey-3.5-tests-version-gitless.patch')
-rw-r--r--app-crypt/libnitrokey/files/libnitrokey-3.5-tests-version-gitless.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/app-crypt/libnitrokey/files/libnitrokey-3.5-tests-version-gitless.patch b/app-crypt/libnitrokey/files/libnitrokey-3.5-tests-version-gitless.patch
new file mode 100644
index 000000000000..99fc5af03787
--- /dev/null
+++ b/app-crypt/libnitrokey/files/libnitrokey-3.5-tests-version-gitless.patch
@@ -0,0 +1,18 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -129,7 +129,14 @@
+ ERROR_QUIET
+ )
+ ENDIF()
+-IF((NOT ${ADD_GIT_INFO}) OR (${PROJECT_VERSION_GIT_RETURN_CODE}))
++# the version.h generation logic is tricky in a number of ways:
++# 1. git describe on a release tarball will always fail with
++# a non-zero return code, usually 128
++# 2. If git is not installed, PROJECT_VERSION_GIT_RETURN_CODE
++# will contain the string 'No such file or directory'
++# Hence fallback to PROJECT_VERSION when the return code is NOT 0.
++IF((NOT ${ADD_GIT_INFO}) OR (NOT ${PROJECT_VERSION_GIT_RETURN_CODE} STREQUAL "0"))
++ MESSAGE(STATUS "Setting fallback Git library version")
+ SET(PROJECT_VERSION_GIT "v${PROJECT_VERSION}")
+ ENDIF()
+ MESSAGE(STATUS "Setting Git library version to: " ${PROJECT_VERSION_GIT} )