summaryrefslogtreecommitdiff
path: root/app-crypt/jetring/jetring-0.27.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/jetring/jetring-0.27.ebuild')
-rw-r--r--app-crypt/jetring/jetring-0.27.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-crypt/jetring/jetring-0.27.ebuild b/app-crypt/jetring/jetring-0.27.ebuild
new file mode 100644
index 000000000000..fe2d14100c31
--- /dev/null
+++ b/app-crypt/jetring/jetring-0.27.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="GPG keyring maintenance using changesets"
+HOMEPAGE="http://joeyh.name/code/jetring/"
+SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="app-crypt/gnupg"
+RDEPEND="
+ ${DEPEND}
+ dev-lang/perl
+ "
+
+S="${WORKDIR}"/${PN}
+
+src_prepare() {
+ eapply "${FILESDIR}"/${PN}-0.21-parallel.patch
+ eapply_user
+}
+
+src_compile() {
+ addpredict "/run/user/$(id -u)/gnupg/"
+ default
+}
+
+src_install() {
+ default
+
+ insinto /usr/share/${PN}/
+ doins -r example
+
+ doman ${PN}*.[0-9]
+}